Issue 83670 - [CWS langstatusbar] Letter wizard not working and office can not be closed normally thereafter
Summary: [CWS langstatusbar] Letter wizard not working and office can not be closed no...
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: current
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2007-11-15 15:44 UTC by stefan.baltzer
Modified: 2013-08-07 14:42 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description stefan.baltzer 2007-11-15 15:44:50 UTC
Found by Autotest "f_updt_wizard_letter.bas" Is OK in master SRC680_m232. Occurs
on Win, Linux, Solaris alike. 

To reproduce:
File - Wizards - Letter
-> Letter wizard is not coming up. Some nag is shown in terminal (see below).
Thought the office seems to work normally (NO freeze), it can not be closed
normally thereafter. Neither File-Exit nor the window closer work. The soffice
process must be killed manually. 

Terminal output:
 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - 
com.sun.star.lang.IllegalArgumentException: 
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java:183)
        at $Proxy19.invoke(Unknown Source)
        at com.sun.star.wizards.common.Resource.getStringList(Resource.java:76)
        at com.sun.star.wizards.letter.LocaleCodes.<init>(LocaleCodes.java:15)
        at
com.sun.star.wizards.letter.LetterWizardDialogImpl.initializeNorms(LetterWizardDialogImpl.java:895)
        at
com.sun.star.wizards.letter.LetterWizardDialogImpl.startWizard(LetterWizardDialogImpl.java:125)
        at
com.sun.star.wizards.letter.CallWizard$WizardImplementation.trigger(CallWizard.java:95)
 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Comment 1 thomas.lange 2007-11-19 10:50:58 UTC
Fixed in CWS langstatusbar.

TL->SBA: Thanks for finding this one. It could never have been found unless
falling in that trap.
Comment 2 thomas.lange 2007-11-19 12:08:36 UTC
.
Comment 3 stefan.baltzer 2007-11-21 13:17:26 UTC
SBA: Verified in re-built and re-synced (to m237) CWS langstatusbar.
Comment 4 ht990332 2008-01-13 12:09:07 UTC
I still see this same exact bug in OOH680_m1 
Can someone please take a look?
Comment 5 ht990332 2008-01-22 19:42:15 UTC
bug is still there in ooh680_m3 as well
Comment 6 carsten.driesner 2008-01-23 10:21:42 UTC
cd: Reopen issue as problem occurs on OOH680m4.
Comment 7 carsten.driesner 2008-01-23 10:22:13 UTC
cd: Take issue.
Comment 8 carsten.driesner 2008-01-23 10:24:15 UTC
cd: Add keyword regression.
Comment 9 jolatt 2008-01-23 17:15:58 UTC
Just now I installed OOH680m4 under Windows XP Home SP2 and I cannot confirm
this Issue. The letter wizard comes always up.
Comment 10 jolatt 2008-01-23 17:19:45 UTC
Forgot: I use jre1.6.0_04.
Comment 11 mikhail.voytenko 2008-01-24 11:37:59 UTC
*** Issue 84209 has been marked as a duplicate of this issue. ***
Comment 12 carsten.driesner 2008-01-25 10:44:48 UTC
cd: I am also not able to reproduce this issue anymore. I could see it once on
my machine, but may be I didn't wait long enough. The wizards use Java and Java
must be started and initialized first in OpenOffice.org. The startup can
sometimes last a little bit longer and people tend to think that OpenOffice.org
freezed. I checked OOH680m3 and m4 under Windows and Linux. I also checked
SRC680m238 on Linux 32-Bit (no 64-bit version available) and the Letter wizards
opened every time. Using different Java versions (1.4.2-1.6.0) made no
difference. Sometimes it needed about 10 seconds, but most of the time about 3
seconds.

If someone can provide a scenario where I can reproduce it you can open it
again. Currently I have to close it as WORKSFORME.
Comment 13 carsten.driesner 2008-01-25 10:46:54 UTC
cd: Closed.
Comment 14 rene 2008-01-28 13:54:56 UTC
cd: I can reproduce it at will here..
The argument about the time does not make that much sense, imho, as the error
message (com.sun.star.lang.IllegalArgumentException) on the terminal indicates a
real error and not just timing..
Comment 15 rene 2008-01-28 13:57:38 UTC
(that said, I don't know the cause either, but...)
Comment 16 rene 2008-01-28 14:40:13 UTC
reopened. (as discussed in release status meeting)
Comment 17 carsten.driesner 2008-01-28 14:46:14 UTC
cd->rene: Under Windows you cannot see any message in a terminal. To be sure you
have to until the Letter Wizard is shown or you run into your personal "timeout". 
If you can reproduce it please provide detailed information about your platform
and OpenOffice.org version.

My test platforms:
Linux: Kubuntu 7.10 and OOH680m3/m4 32-Bit, Java 1.4.2, 1.5.0, 1.6.0
Windows: Windows XP SP2, Windows 2003 Server and OOH680m3/m4 32-Bit, Java 1.4.2,
1.5.0, 1.6.0
Comment 18 carsten.driesner 2008-01-28 14:53:47 UTC
cd: Set mba and os on CC.
Comment 19 rene 2008-01-28 15:01:35 UTC
OOH680_m4 built with ecj as java compiler on Debian sid, x86_64 (no other
option, until IcedTea/OpenJDK is in Debian, and then we'd still don't have free
Java on e.g Sparc).
Not that it should matter as even your (Suns) autotests discovered this...

Doesn't work with any JVM; tried gcj, Sun 1.5, Sun 1.6.

cd: why are you asking anyway? Even yourself was able to reproduce it once? And
the issue mentions terminal output  so you probably should test there and run it
from a terminal instead of telling "on Windows there isn't terminal output",
(can't you start the office from a cmd.exe?)
Comment 20 carsten.driesner 2008-01-29 07:23:17 UTC
cd->os: Please take over.
Comment 21 stefan.baltzer 2008-01-31 15:24:45 UTC
This one affected 32bit systems too, currently (OOH680m5) only 64-bit systems
seem to be affected. Therefore I will re-open issue 84209 and close this one.
Comment 22 stefan.baltzer 2008-01-31 15:30:09 UTC
Reassigned to me. Removed link to issue 84957.
Comment 23 stefan.baltzer 2008-01-31 15:33:07 UTC
SBA: Closed.