Issue 84338 - Printing to default printer from document created from a OOo-2.x-template prints to printer stored in the template
Summary: Printing to default printer from document created from a OOo-2.x-template pri...
Status: CLOSED DUPLICATE of issue 75342
Alias: None
Product: Writer
Classification: Application
Component: printing (show other issues)
Version: OOo 2.3.0 RC1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-07 10:20 UTC by rkollien
Modified: 2008-01-09 14:56 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description rkollien 2007-12-07 10:20:06 UTC
CentOS 5 Server, OOo-RPM-install 2.3.0 from OOo-Website (no!! CentOS-RPMs)


Dear Sirs, 
we use several templates stored on a central location on the server. The
templates are used to create documents. The templates currently are all created
with the old OOo 1.1.5. Now, when a user opens such a template with OOo 2.3, a
document is created as expected. Clicking on "direct printing" prints the
document at the USERS DEFAULT printer. So far, so good. Now when we open the
template itself with 2.3 and store it, ether as a .stw or as a .ott, at this
moment, all new documents based on this templates are printed to the printer
STORED IN THE TEMPLATE (which is the default printer of the maintainer of the
template). If this printer isn't available, the SYSTEM DEFAULT PRINTER is used.
To print to the users printer, you have to go to "File->Print" and choose the
correct printer. Pre-assigned in the printing dialog is ether the maintainers
printer (if available) or the system default printer. This is very unfunny.

We tried to delete the stored printer, resp. deleted the string completely, in
the settings.xml by hand, but this only leads to printing on the system default
printer (as a empty or the non-existing printer isn't available). This DOESN'T
happen, when you use a unmodified 1.1.5-template (even the printer is stored
within the settings.xml, too).

This is very unusable in the case of:
a) We have several templates which use a basic macro and button to print forms.
The macro command "doc.print(...)" now prints all newly created documents to the
maintainers printer! And she's not very happy about...
b) Some forms created with 1.1.5 look very ugly in 2.x, as some controls are no
more at the designated place on the page. So unluckily we must correct the
template with 2.x. And, as above written, it doesn't matter if you save the
template in 1.x-format or 2.x-format. At the moment, OOo 2.x saves a template,
all further printing goes to the maintainer or system default printer.

BTW: It doesn't matter, if the template is printed before saving. The
maintainers printer always is saved in the template. Does it make any sense,
storing a printer in the document? Maybe this is funny on a single workplace,
but catastrophic on server based systems where many people work with same
documents/templates an all have access to all printers (or at least the system
default).

Regards,
Rudolf
Comment 1 michael.ruess 2007-12-07 11:24:02 UTC
Reassigned to HI.
Comment 2 kpalagin 2008-01-09 14:55:28 UTC
I think this is duplicate to http://qa.openoffice.org/issues/show_bug.cgi?
id=75342.



*** This issue has been marked as a duplicate of 75342 ***
Comment 3 kpalagin 2008-01-09 14:56:20 UTC
Closing.

Please vote for 75342.