Issue 84584 - Adobe Flash plugin v9 doesn't work
Summary: Adobe Flash plugin v9 doesn't work
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Impress
Classification: Application
Component: viewing (show other issues)
Version: OOO300m9
Hardware: PC Linux, all
: P3 Trivial with 3 votes (vote)
Target Milestone: OOo 3.3
Assignee: wolframgarten
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks: 95002
  Show dependency tree
 
Reported: 2007-12-14 22:11 UTC by sthibaul
Modified: 2010-08-17 13:34 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
flash animation (860.12 KB, application/x-shockwave-flash)
2007-12-15 14:15 UTC, sthibaul
no flags Details
impress file that embeds the flash animation (10.11 KB, application/vnd.oasis.opendocument.presentation)
2007-12-15 14:16 UTC, sthibaul
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description sthibaul 2007-12-14 22:11:48 UTC
Hello,

Version 9 of the Adobe Flash plugin doesn't work in OpenOffice.org, so that I'm
stuck with version 7.

- new presentation
- Insert->Object->Plug-in
- Browse
- Select Shockwave Flash (*.swf) type
- Select a file, Open, OK

With version 7 of the plugin, the flash animation shows up fine. With version
9, it shows up as a gray rectangle, and on the console, the warnings below is
output.  Since the plugin works fine in mozilla, I guess the issue is with
openoffice.org.
Could it just be that openoffice.org doesn't call NP_Initialize() properly for
instance?

(process:32741): GLib-GObject-CRITICAL **: /tmp/buildd/glib2.0-2.12.12/gobject/gtype.c:2242: initialization assertion failed, use IA__g_type_init() prior to this function

(process:32741): Gtk-CRITICAL **: gtk_clipboard_get_for_display: assertion `GDK_IS_DISPLAY (display)'
Adobe FlashPlayer: gtk_clipboard_get(GDK_SELECTION_PRIMARY); failed. Trying to call gtk_init(0,0);
GTK Accessibility Module initialized
The program '<unknown>' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 108 error_code 2 request_code 12 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Samuel
Comment 1 shaunmcdonald131 2007-12-15 11:56:11 UTC
Can you please attach a sample swf for us to test.
Comment 2 sthibaul 2007-12-15 14:15:36 UTC
Created attachment 50336 [details]
flash animation
Comment 3 sthibaul 2007-12-15 14:16:12 UTC
Created attachment 50337 [details]
impress file that embeds the flash animation
Comment 4 christian.guenther 2008-02-13 11:44:52 UTC
Duplicate to issue 49989

*** This issue has been marked as a duplicate of 49989 ***
Comment 5 christian.guenther 2008-02-13 11:47:26 UTC
I close the issue as duplicate.
Comment 6 sthibaul 2008-02-13 12:11:41 UTC
Well, that's not a duplicate: 49989 was about flash working in edit mode but not slide show mode, and that got fixed and does now work great with flash 7.  This bug is about flash 9 which doesn't work at all, even in edit mode, and will require a completely different kind of fixup.
Comment 7 sthibaul 2008-04-11 00:29:22 UTC
I've googled a bit, it looks like what is missing for flashplugin 9 is the XEmbed support.
Comment 8 wolframgarten 2008-09-05 12:45:47 UTC
Reassigned.
Comment 9 wolframgarten 2008-10-06 12:33:18 UTC
Reproducible. Reassigned.
Comment 10 philipp.lohmann 2008-10-07 14:42:06 UTC
what is missing is actually a gtk environment. The flash plugin seems to be
relying on that nowadays which is sort of bad since our plugin executable is
athena widget based. Which means we need a new plugin executable. Not so trivial.
Comment 11 philipp.lohmann 2008-10-16 12:22:03 UTC
fixed in CWS swffixes

some issues: flash crashes at end (only the plugin, no influence on the OOo
process) which leads to ugly assertions on the command line. Also some of the
context menu entries of flash do not work. ->issue 95002

However shockwave/flash is now played again which is some improvement.
Comment 12 philipp.lohmann 2008-10-24 14:30:19 UTC
please verify in CWS swffixes
Comment 13 wolframgarten 2008-10-29 14:17:33 UTC
Verified in CWS. Still the plugin does not work correctly. Following issue: i95591.
Comment 14 sthibaul 2008-12-22 22:34:40 UTC
Verified in Debian's 1:3.0.1~rc1-1
Comment 15 sthibaul 2009-09-18 13:23:11 UTC
Broken again in debian's 1:3.1.1-1, i.e. OOO310m19 (Build: 9420)
Comment 16 sthibaul 2009-09-18 14:34:19 UTC
I'm getting

Not GTK2 toolkit (got 0).

according to grep, this message comes from libflashplayer.so itself.
Comment 17 Martin Hollmichel 2010-03-05 14:37:05 UTC
move target to 3.3
Comment 18 wolframgarten 2010-08-17 13:22:48 UTC
Tested a file with 3 swf files on three slides on Suse with OOO330_m3 and Flash
Plugin 9.0.124.0, works. Please feel free to reopen if there are still problems.
Thanks.
Comment 19 wolframgarten 2010-08-17 13:24:17 UTC
Closed.
Comment 20 sthibaul 2010-08-17 13:34:26 UTC
Confirmed with Debian's OpenOffice 1:3.2.1-4 and flashplugin-nonfree 2:10.1.53.64.1.