Issue 84795 - hebrew hyperlinked text is gibrish
Summary: hebrew hyperlinked text is gibrish
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: editing (show other issues)
Version: OOo 2.3
Hardware: PC All
: P3 Trivial with 12 votes (vote)
Target Milestone: 3.4.0
Assignee: wolframgarten
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-20 13:24 UTC by Unknown
Modified: 2017-05-20 10:22 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
problems hebrew hyperlinked text (122.13 KB, image/png)
2007-12-20 13:26 UTC, Unknown
no flags Details
proposed patch (1.08 KB, patch)
2008-12-15 12:45 UTC, alan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2007-12-20 13:24:37 UTC
I go to Insert->Hypertext and set the caption to be in hebrew. All ok. But: if
copy-paste that text, then the hebrew is broken and I see strange unicode chars.
A screenshot is attached.
Comment 1 Unknown 2007-12-20 13:26:08 UTC
Created attachment 50488 [details]
problems hebrew hyperlinked text
Comment 2 kaplanlior 2008-04-09 11:35:36 UTC
Confirmed with Impress 2.4.0.

Please change status to NEW.
Comment 3 niska 2008-04-09 22:57:28 UTC
*** Issue 84795 has been confirmed by votes. ***
Comment 4 alan 2008-12-15 12:45:16 UTC
Created attachment 58825 [details]
proposed patch
Comment 5 alan 2008-12-15 12:48:57 UTC
The patch I've attached works for Hebrew and Latin hyperlinked text. Since I've
removed some code, please check that it doesn't break anything else.
Comment 6 alan 2008-12-21 18:30:00 UTC
I'd like to make sure that this patch doesn't fall through the cracks. Can
anyone review this patch? It's fairly simple.
Comment 7 clippka 2010-06-10 15:08:20 UTC
cl->ayaniger: sorry this actually has fallen through the cracks :-/ I'm taking
over for review but I fear this patch is obsolete since we will switch to xml
based clipboard soon. (which fixes the issue anyway so not a bad news)
Comment 8 kaplanlior 2010-08-14 13:07:31 UTC
kaplan->cl: Any news about this?

Still happens with OpenOffice.org 3.2.1 (OOO320m19).
Comment 9 clippka 2010-10-11 17:14:42 UTC
talked to mt about this. since there is no binary exchange with older versions
using this code I removed the encoding and decoding and write/load the original
unicode strings.

I also did this for the author field. Not checked yet but when copy an author
field with non us ascii characters it should fail also, now fixed.

fixed in cws impress202
Comment 10 sven.jacobi 2010-10-15 15:09:18 UTC
changed target to OOo3.4
Comment 11 clippka 2010-11-16 11:56:26 UTC
verified in cws, back to qa
Comment 12 wolframgarten 2010-11-24 15:24:42 UTC
Verified in CWS.