Issue 85101 - testscripts issue block TCM process
Summary: testscripts issue block TCM process
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: QA
Classification: Unclassified
Component: testscripts (show other issues)
Version: current
Hardware: PC Windows XP
: P2 Trivial
Target Milestone: ---
Assignee: redflagzhulihua
QA Contact: issues@qa
URL:
Keywords:
Depends on:
Blocks: 84405
  Show dependency tree
 
Reported: 2008-01-09 09:15 UTC by redflagzhulihua
Modified: 2008-01-10 08:16 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description redflagzhulihua 2008-01-09 09:15:05 UTC
Hi, all,

TCM Localization27 test have now in progress. And will end on Jan. 21st.

But it seems that there are some issues in testscript block this process.

After we update the scripts form CVS, then run testtool to test OOo2.4,
scripts can't run, there is a error hint in the status bar of 
testtool: "unexcept symbol:CRLF", and testtool stop at Line 544 of the 
script: "global\system\inc\master.inc". 

Test case in TCM tell us we should download the latest script. And now, we are 
blocked.

We must submit the testresult before Jan. 21st, So it's quite an urgency. So I 
set the priority to P1.
Comment 1 jogi 2008-01-09 10:35:55 UTC
no P1er, no affect to OOo...
Comment 2 jogi 2008-01-09 10:39:38 UTC
@hde: Windows. Can you reproduce that issue?
Comment 3 helge.delfs 2008-01-09 11:00:01 UTC
hde->redflagzhulihua: This is currently not reproducable by me. Please assure
that you've checked out these files with Unix LF on Windows. If you are using
WinCVS this can be easily changed in checkout-options. If not, please provide
some more information and attach your master.inc. TIA
Comment 4 helge.delfs 2008-01-09 11:04:04 UTC
.
Comment 5 peter.junge 2008-01-09 11:48:14 UTC
Hi Zhu Lihua,

AFAIR Zhang Hong had the same problem a couple weeks ago. Please ask her how the
problem was solved.

Best regards
Peter
Comment 6 peter.junge 2008-01-09 12:11:41 UTC
Hi Zhu Lihua,

I have performed a fresh CVS checkout of the qa/qatesttool main branch using the
command line under Linux. This should avoid any like break issues.
We can copy it tomorrow to your computer.

Best regards
Peter
Comment 7 redflagzhulihua 2008-01-09 12:45:54 UTC
Hi, hde,
I'll attach the file when I'm back to work. And I'll check the settings of CVS. 
Thank you.

Hi, Peter,
I've asked Zhang Hong, She hasn't solve the problem. She just use the old files 
in "global" directory.
But this test case specify the latest script.
Comment 8 redflagzhulihua 2008-01-10 05:45:38 UTC
Hi, hde and pj,

This is a CVS client problem.

Thank you.

Close
Comment 9 jogi 2008-01-10 08:16:23 UTC
You are welcome.
A suggestion for the next time you run in such problems: Try to use the
mailing-list for such [AUTOMATION] issues mailto:dev@qa.openoffice.org because
"urgent" is in our scope not really +10 days :-) We're stll available all
workdays ....