Issue 85257 - indents not fit the habit of chinese people
Summary: indents not fit the habit of chinese people
Status: RESOLVED FIXED
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: 680m241
Hardware: All All
: P3 Trivial (vote)
Target Milestone: 4.2.0
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: CJK
Depends on:
Blocks: 84405
  Show dependency treegraph
 
Reported: 2008-01-15 08:15 UTC by redflagzhulihua
Modified: 2016-03-22 23:46 UTC (History)
7 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description redflagzhulihua 2008-01-15 08:15:18 UTC
In Indents & Spacing tab of paragraph dialog, There is a first line setting and 
a automatic checkbox.
When Automatic is checked, the first line indents of the paragraph is set to 1 
Chinese character(seems 2 English characters in English version). This doesn't 
fit the Chinese Text specification. Chinese Text always indents 2 Chinese 
characters in the first line.

I think this setting should modify to 2 Chinese characters, at least in Chinese 
locale. 

I don't know the default first line indents of western language. Can we set it 
separately in software according the locale setting?
Comment 1 michael.ruess 2008-01-15 11:27:31 UTC
The automatic setting is not depending on the script type - it depends on the
current font size. The larger the font is set by the user, the larger the indent
will be.
Comment 2 michael.ruess 2008-01-15 11:28:19 UTC
Closed.
Comment 3 redflagzhulihua 2008-01-15 12:56:36 UTC
It should depend on the font size, Chinese indent also depend on font size.

But the indent value is too small. double of that value is needed. 

That value of indent is no use to Chinese people. Because this is a incorrect 
format in Chinese writing rule. All Chinese user will think this is a defect. 

In a Chinese article, no matter what font size the character is, always 2 
characters of that font size indent in the first line.
Comment 4 peter.junge 2008-01-15 13:30:37 UTC
Hi Zhu Lihua,

please ask our developers if they already know the problem. I think I remember,
that I heard about this issue before. At least Hu Caiyong mentioned it in his
keynote at the last OOoCon in Barcelona as an example for missing features for
Chinese language. ;-) It's likely, that our OS department has it already on the
to do list.

Peter
Comment 5 redflagzhulihua 2008-01-16 01:40:23 UTC
Hi, Peter,

Yes, this is a known old issue. But it's still there till OOo2.4. And I didn't 
find the record in issuetracker.

As far as I know, all the other Chinese word processor implemented this 
feature, include WPS office and MS word.
Comment 6 frank.meies 2008-01-16 10:26:12 UTC
The "automatic first line indent" flag sets the first line indent based on the
current font size and the line spacing of the paragraph. Please note that
changing this can result in layout incompatibilities for existing documents
which make use of this feature.
Comment 7 pflin 2008-01-23 09:36:57 UTC
As redflagzhulihua said, current behavior of automatic indent doesn't meet the
habit of Chinese. 

Most text documents and web pages in China, the first line of a paragraph is
always indented 2 Chinese characters.

So I think it is better to change current behavior of automatic indent when the
locale is China.

Comment 8 michael.ruess 2008-02-08 14:01:35 UTC
Reopening - maybe there could be a solution for Chinese OOo (or Chinese documents).
Comment 9 michael.ruess 2008-02-08 14:04:35 UTC
MRU->FME: could you please do an evaluation of how this could be solved for
Chinese habits? Maybe in Chinese OOo UI, automatic indent could mean two times
the font height? Or in Chinese character format?
Comment 10 chenxing 2008-11-18 13:51:35 UTC
It seems that the problem is not solved yet in OOo 3.0. I think this is a bug
rather than an enhancement. Without correct indent on first line of a Chinese
paragraph, typesetting Chinese text is extremely tedious! And this is one the
most important reasons why Chinese users doesn't OpenOffice.org to write documents.

I think introduce the "character unit" into the "first line indent" function may
solve the problem.

About Character Unit and Chinese character:
http://wiki.services.openoffice.org/wiki/Character_unit
Comment 11 oooforum (fr) 2015-08-21 06:49:19 UTC
See issue 126476
Comment 12 Kay 2016-03-22 23:46:50 UTC
see issue: https://bz.apache.org/ooo/show_bug.cgi?id=126476