Issue 85461 - Pasting text between different OOo instances might change font settings
Summary: Pasting text between different OOo instances might change font settings
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOH680m2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
: 89639 (view as issue list)
Depends on:
Reported: 2008-01-22 07:48 UTC by cno
Modified: 2017-05-20 10:48 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description cno 2008-01-22 07:48:27 UTC
1. Type text in OOo 2.3.1 (OOG680_m9, build1)
with style default (that has font Verdana, 12 pt.)

2. Now start OOo 2.4-Dev (680m2(build 9250) ) and type something there.
   (it has the style default, which has the font TNR 12)

3. copy and paste it to the first document (in 2.3.1)

4. Now the style in the first document, changes to the properties of the style
in 2.4.0_dev

(5. Undo does not change the style back.)

Never seen that before.
When I copy from one doc to another in 2.4.0_dev, the style, that is already
used in the document I past to, remains unchanged.
When I copy from 2.3.1 to 2.4.0_dev, the style, that is already used in the
document I past to, remains unchanged.
When I change the style in 2.4.0_Dev and past to 2.3.1, the style in 2.3.1
changes to TNR as well.
When I type in Heading 1 in  in 2.4.0_Dev and past to 2.3.1, the whole text in
2.3.1 changes to default/TNR as well.
Comment 1 thorsten.ziehm 2008-01-22 10:32:59 UTC
Hi Herbert,

could this be a side effect by the change with the FontConfig?
Comment 2 2008-01-22 11:23:43 UTC
@thorstenziehm: No, the style settings are on the application level. Reassigning the issue to AMA.
The fontconfig integration might cause some visual changes between 2.3.1 and 2.4.0_Dev though if the 
problem happened on X11 platforms.
cornouws: I read the bug report a couple of times but couldn't figure out the platform where the problem 
happens. Could you provide this detail?
Comment 3 cno 2008-01-22 11:59:29 UTC
Hi Herbert, Thorsten,
Sorry I forgot to mention: this one is on Windows XP.
Comment 4 cno 2008-01-24 07:36:49 UTC
Tried with OOH680_m4
In between, had a different default template in that installation.

- Started a document in 2.4-dev
- Changed Default to TNR 11.
- Copied and pasted to 2.3.1 with Default Verdana 12.
-> All in the 2.3.1 document changed to TNR 12.
Comment 5 cno 2008-01-25 15:33:01 UTC
even choosing Paste special>Unformatted text causes the change
Comment 6 Regina Henschel 2008-01-25 17:41:02 UTC
I tried with OOH680m4 and OOo231 de on WinXP. Pasting as "unformatted text" and
as "rtf" do work correct. Pasting as "OOo-dev 2.4 Text Dokument" changes the
font in Tools-Options-Writer-Base Fonts-Default as cornouws described.
Comment 7 jbf.faure 2008-01-25 18:47:08 UTC
I tried with OOH680_m4 and 2.3.1 FR on Kubuntu 6.06. Only pasting as Formatted
text (RTF) do work correct. Other pasting modes restore default font in 2.3.1.
Comment 8 andreas.martens 2008-01-28 08:39:03 UTC
I reproduced this behavior with StarOffice 7 and StarOffice 8.0, so I assume it
happens with OOo1.0 and OOo1.1 as well. So I wonder why this is a potential show
The following happens:
if you change the default font via tools/options/.. for a document and paste
text from this document into a document opened by another office version then
this font value (tools/options...) is overwritten.
This is not nice and should be changed but it happens since the beginning of
Writer. I'm not sure if we are able to change this behavior when we copy into
older versions but surely we will find a fix for future versions.
Work-around: because Undo does not repair the font setting, you have to change
the font back to the old value (tools/option...) or via stylist.
Comment 9 cno 2008-01-28 11:22:47 UTC
Hi ama,
I do have the idea that there is something special.

See this part from my first comment:
"When I copy from 2.3.1 to 2.4.0_dev, the style, that is already used in the
document I paste to, remains unchanged."
So, copying from SO7/8 to 2.4-dev, works different than copying from 2.4-dev to 
SO7/8. If what I noticed is the same for you, of course ...
Comment 10 andreas.martens 2008-01-28 11:49:47 UTC
I tried the following:
1. Start OOo2.4-dev,
2. Type some text => it is displayed with font "Thorndale" (which is my 2.4 default)
3 .Start OOo1.0
4. Change via tools/options/text document/Basic fonts Western to e.g. "Verdana"
5. Type some text => displayed in "Verdana"
6. Select this text and copy into clipboard
7. Paste it into OOo2.4-dev document
8. => All text (not only the freshly inserted) changed into "Verdana" (Bug!)
9. A look into tools/options shows "Verdana" instead of "Thorndale"
If I copy from OOo2.4 into OOo1.x, the same bug occurs.
BTW: the bugs does _not_ occur if I change the default font in the destination
office within the stylist!

What's your scenario, when do OOo2.4 and OOo2.3.1 show different behavior?

Comment 11 cno 2008-01-28 20:32:24 UTC
My steps:
1- Open Writer 2.3.1
2- Type some text on one line
3- Change the style to Text body, and the props of that to - lets say - Arial
Black 8 pt.
4- Open Writer 2.4-dev (680_m4) 
5- Type some text on one line
6- Change the style to Text body, and the props of that to - lets say - in Comic
Sans 14pt
7- Select and copy this text
8- Go to 2.3.1, to the end of the text
9- Ctrl-V
	- > text changes to style Default, TimesNewRoman, 12 pt

When I do the same with 2.4-dev and 2.3.1 dev exchanged (so in step 1 and 8
2.4-dev and in step 4 2.3.1) then after step 9, the text changes to style
Default, Verdana 10,5 

In 2.4-dev verdana 10.5 is the default
In 2.3.1 TNR 12 *isn't* the default (it's Verdana 12 there).

Other example
1. type some text in style Text body (Verdana 12 pt in this case) in 2.3.1
2. then some empty paragraphs
3. Type some text in Heading 1 (Arial 16.1 pt) in 2.4-dev
4. Copy
5. Go to 2.3.1, to one of the empty paragraphs and paste
	-> paragraph changes to Default, TNR 12 and also the first paragraph becomes TNR

So basically: every time I paste from 2.4-dev to 2.3.1, the style changes to TNR 12.
Comment 12 andreas.martens 2008-01-29 09:22:15 UTC
ama->sba: I set you to cc. Please have a look if you find a new bug
(regression). I found some bugs but not really new ones?! So I doubt this one is
really a show stopper for OOo2.4.
Comment 13 Oliver Specht 2008-02-01 10:34:24 UTC
Pasting works like loading. That's why default attributes like those in
..Writer/Default fonts are changed once a Writer document is pasted into another
one. The same should apply for all other defaults (like document locales). It
definitely makes sense to prevent that but it is by no means a regression.

As this is definitely an old problem I change the target to OOo 3.x and remove
it from the 2.4 show stopper issue.
Comment 14 cno 2008-02-05 13:43:10 UTC
Hi Oliver,
Still cannot understand how I can have party different behavior, but accept that
the bulk of the issue is old.
Comment 15 Oliver Specht 2008-02-06 07:00:12 UTC
->cornouws: Sorry, I don't know why.
Comment 16 cno 2008-07-01 23:02:12 UTC
IMO 89639 is the same issue
Comment 17 Oliver Specht 2008-07-02 06:43:29 UTC
*** Issue 89639 has been marked as a duplicate of this issue. ***
Comment 18 eberlein 2008-07-02 07:23:44 UTC
Please change the summary because it is related to all versions (see dupe issue
Comment 19 Oliver Specht 2008-07-03 08:18:10 UTC
Changed summary.
Comment 20 cno 2008-11-17 19:44:27 UTC
I think this is a related post:
Comment 21 Marcus 2017-05-20 10:48:18 UTC
Reset assigne to the default "".