Issue 85657 - downloadtemplate.nsi fail with invalid command: ${LangFileString} error
Summary: downloadtemplate.nsi fail with invalid command: ${LangFileString} error
Status: CLOSED FIXED
Alias: None
Product: Build Tools
Classification: Code
Component: code (show other issues)
Version: OOH680m4
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: OOo 3.0
Assignee: Olaf Felka
QA Contact: issues@tools
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-29 02:09 UTC by grakic
Modified: 2008-04-25 10:19 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Log file (413.77 KB, text/plain)
2008-01-29 02:11 UTC, grakic
no flags Details
File with ${LangFileString} issue (6.99 KB, text/plain)
2008-01-29 02:14 UTC, grakic
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description grakic 2008-01-29 02:09:49 UTC
ERROR: The following errors occured in packaging process:

ERROR: c:/PROGRA~1/NSIS/makensis.exe d:/OOH680_m4/instsetoo_native/wntmsci11.pro
/OpenOffice/msi/nsis/en-US/downloadtemplate.nsi | !
!include: error in script: "d:/OOH680_m4/instsetoo_native/wntmsci11.pro/OpenOffi
ce/msi/nsis/en-US\English_pack.nsh" on line 7
Error in macro MUI_LANGUAGE_PACK on macroline 3
Error in script "d:/OOH680_m4/instsetoo_native/wntmsci11.pro/OpenOffice/msi/nsis
/en-US/downloadtemplate.nsi" on line 231 -- aborting creation process


The issue in this case is "Invalid command: ${LangFileString}".

Please reasign if component I selected is wrong.
Comment 1 grakic 2008-01-29 02:11:08 UTC
Created attachment 51213 [details]
Log file
Comment 2 grakic 2008-01-29 02:14:10 UTC
Created attachment 51214 [details]
File with ${LangFileString} issue
Comment 3 Martin Hollmichel 2008-01-29 05:33:06 UTC
reassign issue.
Comment 4 grakic 2008-01-29 06:58:02 UTC
I have NSIS 2.34, maybe that is the source of a problem?

Earlier in the setup I had to copy Language folder inside NSIS instalation to
"Modern UI" folder to get around previous "Missing file" error.
Comment 5 ingo.schmidt-rosbiegal 2008-01-29 09:24:58 UTC
It is not so simple to exchange the nsis version. There are many macros that
change and also many replacements, that we are doing in the nsi file. This
mechanisms break when using an unsupported nsis version. Currently we are using
nsis 2.0.4. There is already a task (i84827) to update this to a newer nsis version.
 
Comment 6 grakic 2008-01-30 17:10:30 UTC
Works with 2.0.4. Thanks.

I'll write an update for /Building_OOo_with_Cygwin_on_Windows Wiki page.
Comment 7 ingo.schmidt-rosbiegal 2008-02-04 09:50:18 UTC
Try to change to newer nsis version for OOo 3.0.
Comment 8 ingo.schmidt-rosbiegal 2008-02-28 16:37:45 UTC
Usage of nsis 2.3.5 is possible after integration of cws native134.
Comment 9 ingo.schmidt-rosbiegal 2008-02-29 11:51:11 UTC
Fix included into cws native133.
Comment 10 ingo.schmidt-rosbiegal 2008-03-03 11:12:59 UTC
IS -> OF: Please verify, that installation set with NSIS 2.3.5 are as good as
those with NSIS 2.0.4 (or even better :-) )
Comment 11 Olaf Felka 2008-03-05 14:28:56 UTC
OF: Can't find any regressions in cws native133.
Comment 12 Olaf Felka 2008-04-25 10:19:55 UTC
No regressions in NSIS have been found.