Issue 85754 - Screen repaint problem in Form design mode
Summary: Screen repaint problem in Form design mode
Status: CLOSED DUPLICATE of issue 83921
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: recent-trunk
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: dbaneedsconfirm
QA Contact: issues@dba
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-31 04:04 UTC by drewjensen.inbox
Modified: 2008-01-31 10:33 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Bug doc with form (23.85 KB, application/vnd.sun.xml.base)
2008-01-31 04:06 UTC, drewjensen.inbox
no flags Details
Screen shot of redraw problem (71.29 KB, image/png)
2008-01-31 04:07 UTC, drewjensen.inbox
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description drewjensen.inbox 2008-01-31 04:04:37 UTC
Environment - Win XP, 1280 X 1024 res screen, OOH680_m5

Steps to reproduce:
Open the attached bug doc
Open the single form in design mode ( maximized )
Select the sub_form grid control and open the property editor
Position the property editor so that it is partially overlapping the grid
Change the grid Border Style or Background color
The grid is brought to top of the screen z level, on top of the property editor
dialog now - forcing a redraw of the screen will correct.

Also attached a screen shot of the problem.

It appears to only happen with grid controls, and only when the property being
changed causes a redraw of the control itself - did not test if it matters if
the grid is not a sub_form so don't know it that is part of it.
Comment 1 drewjensen.inbox 2008-01-31 04:06:29 UTC
Created attachment 51278 [details]
Bug doc with form
Comment 2 drewjensen.inbox 2008-01-31 04:07:10 UTC
Created attachment 51279 [details]
Screen shot of redraw problem
Comment 3 Frank Schönheit 2008-01-31 10:28:42 UTC
I'm pretty sure this is a duplicate - we already have an issue which says that
table controls overlap the property browser (or any other floating sub windows
of the document window, for that matter). Alas, I can't find it right now.
Comment 4 Frank Schönheit 2008-01-31 10:31:19 UTC
ah, there it is ...

*** This issue has been marked as a duplicate of 83921 ***
Comment 5 Frank Schönheit 2008-01-31 10:33:01 UTC
closing duplicate