Issue 85794 - Reimplement file locking using an additional file.
Summary: Reimplement file locking using an additional file.
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 680m244
Hardware: All All
: P3 Trivial with 1 vote (vote)
Target Milestone: OOo 3.0
Assignee: oc
QA Contact: issues@framework
: 54567 54586 (view as issue list)
Depends on:
Reported: 2008-02-01 10:48 UTC by mikhail.voytenko
Modified: 2008-06-24 08:23 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

TestCaseSpecification (12.96 KB, text/html)
2008-04-22 11:01 UTC, oc
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mikhail.voytenko 2008-02-01 10:48:48 UTC
Currently the system file locking does not always work as expected in case of
using of network file systems. To avoid the problems the file locking will be
implemented using an additional lock-file.

Currently it is planned to do it only for own file formats.
Comment 1 hennes.rohling 2008-02-04 11:35:37 UTC
*** Issue 54567 has been marked as a duplicate of this issue. ***
Comment 2 thomas.benisch 2008-03-06 13:51:51 UTC
cc tbe
Comment 3 mikhail.voytenko 2008-03-26 16:39:04 UTC
The implementation in calcshare2 is ready. All the known bugs are submitted
Comment 4 mikhail.voytenko 2008-04-01 09:25:26 UTC
Please verify the issue.
Comment 5 hennes.rohling 2008-04-02 12:49:16 UTC

Looks OK to me on CWS calcshare2.
Comment 6 Mathias_Bauer 2008-04-07 11:19:29 UTC
*** Issue 54586 has been marked as a duplicate of this issue. ***
Comment 7 oc 2008-04-22 11:01:36 UTC
Created attachment 53109 [details]
Comment 8 clutz 2008-06-13 13:40:45 UTC
I tested the filelocking implementation of OOo3 (300m2 Rev 9301) on Windows and
found the following bugs which lead to data loss:

No File locking for doc-files shared via samba-share:
1) Open a .doc-file that is hosted on a samba-share on Windows-host A
2) Open the same .doc-file on Windows-host B --> file opens editable (!!!BUG!!!)
3) edit the document on host A, save and close the document
4) edit the document on host B, save and close the document

result: changes done in 3) are lost! The file-locking for .doc-Files on windows
is broken.

Another issue affects the file-locking in a heterogenous environment with a file
shared via samba-share, opened in OOo3 on Windows and in OOo2 on linux with
cifs-mount (the bug is reproducible with .doc AND .odt-files):
1) Open a .odt/.doc-file on a Windows host A with OOo3
2) Open the same .odt/.doc-file on a linux-client B with OOo2 --> file opens
editable (!!!BUG!!!)
3) edit the document on host A and B and save the document.

result: the last save-actions wins, the changes of the first save-action are lost.

Please add these two usecases to your testcase and test again! Please notice
that these usecases are real-world usecases which will occur regulary in our
heterogenous environment while introducing OOo3.

In this point the file-locking implementation of OOo2 is better than OOo3 as
there is no data loss with OOo2 in the same usecases. I think this would be a
blocker for us not to use OOo3.
Comment 9 clutz 2008-06-24 07:10:46 UTC
IMO this issue is not solved completely. Please read my test result from Jun for the reason why.
Comment 10 mikhail.voytenko 2008-06-24 08:20:02 UTC
This issue is solved as it was planned. Please read the description carefully,
it is explicitly mentioned there that the locking will be done only for OOo formats.

If you are not satisfied with the decision not to lock the alien formats files,
please open a new issue and send it to me, and do not reuse the issue that is
correctly solved.
Comment 11 mikhail.voytenko 2008-06-24 08:21:34 UTC
Comment 12 mikhail.voytenko 2008-06-24 08:23:29 UTC