Issue 86098 - crash when switching icons
Summary: crash when switching icons
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 680m246
Hardware: All All
: P2 Trivial (vote)
Target Milestone: OOo 3.0
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords: oooqa
: 86120 88246 (view as issue list)
Depends on:
Blocks:
 
Reported: 2008-02-14 12:32 UTC by Stephan Bergmann
Modified: 2008-08-05 21:39 UTC (History)
3 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
i think the current layout manger 's listener is removed.while the Layout manger is destroyed. (559 bytes, text/plain)
2008-03-06 08:54 UTC, zhoubo.shi
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Stephan Bergmann 2008-02-14 12:32:14 UTC
At least in unxlngi6.pro SRC680m246 OpenOffice.org: start soffice, press F1 to
open help window, in the other window "Tools - Options... - OpenOffice.org -
View - User Interface - Icon size and style" change from "Small" to "Large" and
press "OK":

Program received signal SIGSEGV, Segmentation fault.
#0  0xb22bc0e5 in framework::LayoutManager::implts_getCurrentSymbolsSize
(this=0xb07a7c3c) at readguard.hxx:163
#1  0xb22d739a in framework::LayoutManager::OptionsChanged (this=0xb07a7c3c) at
/so/ws/SRC680/src/framework/source/layoutmanager/layoutmanager.cxx:6233
#2  0xb22d78ac in framework::LayoutManager::LinkStubOptionsChanged
(pThis=0xb07a7c3c, pCaller=0xb1e3d4e4) at
/so/ws/SRC680/src/framework/source/layoutmanager/layoutmanager.cxx:6231
#3  0xb7ae9529 in SvtMiscOptions_Impl::CallListeners (this=0xb1e3d4e4) at
link.hxx:157
#4  0xb7ae95a9 in SvtMiscOptions_Impl::SetSymbolsSize (this=0xb1e3d4e4,
nSet=31848) at /so/ws/SRC680/src/svtools/source/config/miscopt.cxx:532
#5  0xb7ae9941 in SvtMiscOptions::SetSymbolsSize (this=0xbfecbd34, nSet=31848)
at /so/ws/SRC680/src/svtools/source/config/miscopt.cxx:743
#6  0xad351818 in ?? ()
#7  0xbfecbd34 in ?? ()
#8  0x00000000 in ?? ()
Comment 1 urazovl 2008-02-16 04:28:19 UTC
Lachin Urazov
02/18/08
Linked issue 86120.

I could reproduce this defect on MS Windows XP SP 2 running OOo 2.3.1.
I guess a possible work around would be to not change the icon size while using
help, although definitely may be disturbing at times. 

Interesting thing is that it crashes after change is applied, because after the
recovery the icon size takes the new size. Changing from large to small works to
break it as well.
Comment 2 urazovl 2008-02-16 04:34:28 UTC
Lachin Urazov
02/18/08
Linked issue 86120.

I could reproduce this defect on MS Windows XP SP 2 running OOo 2.3.1.
I guess a possible work around would be to not change the icon size while using
help, although definitely may be disturbing at times. 

Interesting thing is that it crashes after change is applied, because after the
recovery the icon size takes the new size. Changing from large to small works to
break it as well.
Comment 3 mci 2008-02-18 19:57:36 UTC
*** Issue 86120 has been marked as a duplicate of this issue. ***
Comment 4 carsten.driesner 2008-02-19 07:41:19 UTC
cd: Set priority to P2 and target to OOo 3.0.
Comment 5 zhoubo.shi 2008-03-06 08:54:52 UTC
Created attachment 51925 [details]
i think  the current layout manger 's  listener is  removed.while the Layout manger is destroyed.
Comment 6 carsten.driesner 2008-03-06 10:09:55 UTC
cd: Set issue type to patch.
Comment 7 carsten.driesner 2008-03-06 10:30:26 UTC
cd: Patch applied to CWS fwk86.
Comment 8 carsten.driesner 2008-04-14 09:29:00 UTC
*** Issue 88246 has been marked as a duplicate of this issue. ***
Comment 9 philipp.lohmann 2008-04-15 09:13:53 UTC
*** Issue 88286 has been marked as a duplicate of this issue. ***
Comment 10 carsten.driesner 2008-04-17 07:28:20 UTC
cd->tm: Please verify.
Comment 11 eric.bachard 2008-04-18 08:16:55 UTC
The patch fixed nothing for me: I still have the crash with DEV300_m8

Are you sure the issue is really fixed ?
Comment 12 Mathias_Bauer 2008-04-18 14:50:03 UTC
"Fixed in CWS fwk86" means that you will see the fix in the master when this CWS
is integrated. As you could see in EIS fwk86 still is in status "New".
Comment 13 eric.bachard 2008-04-18 14:58:38 UTC
@mba

Hi Mathias,

Does it mean the attached patch is not the complete fix  ? ( bonsai shown me no change yet in 
cws_dev300_fwk86 )

I'm sorry, but I don't understand why an issue is set as resolved fixed in some cws, when the code is 
not commited in it ?  Is there an additionnal delay with bonsai and or tunnel ? 


Off Topic: I'll answer your mail asap.

Comment 14 thorsten.martens 2008-05-09 07:19:31 UTC
checked and verified in cws fwk86 -> OK
Comment 15 lohmaier 2008-08-05 21:39:50 UTC
ok in m28 → closing