Issue 86328 - Selection toolbar resets to Unary/Binary after switching to other OO apps
Summary: Selection toolbar resets to Unary/Binary after switching to other OO apps
Status: CLOSED FIXED
Alias: None
Product: Math
Classification: Application
Component: ui (show other issues)
Version: OOo 2.3.1
Hardware: All All
: P3 Trivial with 3 votes (vote)
Target Milestone: 3.4.1
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-21 18:02 UTC by kpalagin
Modified: 2010-10-14 11:28 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description kpalagin 2008-02-21 18:02:05 UTC
Repro steps:
1. Start Writer, start Math.
2. Make sure Selection toolbar is on (View-Selection).
3. Click any button other than first.
4. Switch to Writer. Switch back to Math - first button on Selection toolbar 
is depressed.
Comment 1 michael.ruess 2008-02-22 11:34:14 UTC
MRU->TL: click e.g. "Functions" in the Selection toolbox, switch to other OOo
application window, switch back to Math -> Selection focussed back onto
"Unary/Binary operators"
Comment 2 thomas.lange 2008-03-14 13:50:30 UTC
This happens only when switching between Office applications. It does not when
switching between Math and foreign application.
Thus I suspect it is a framework issue.
Also PL said it is likely framework or maybe him.

TL->CD: Can you have a look? Thanks!
Comment 3 kpalagin 2009-05-19 08:48:35 UTC
Carsten,
any news with this issue?
WBR,
KP.
Comment 4 carsten.driesner 2009-05-19 09:01:19 UTC
cd: No update, hopefully I can give this issue to someone else. Otherwise I
don't see that I can work on this issue in the next weeks. Currently I am
involved in performance optimizations and the next important task is Windows 7
compatibility.
Comment 5 carsten.driesner 2009-05-19 09:25:46 UTC
cd: I couldn't resist to look into the sources for a couple of minutes.
Fortunately I was able to see the root cause. The floating window
SmToolBoxWindow sets the focus to the first entry in the ctor. If a user
switches between OOo document windows the floating window will be
destroyed/created. Therefore the ctor is called again and sets the focus to the
first entry. The implementation needs a way to store the last selection and use
it in the ctor.

cd->tl: Please take over. This is not related to any framework issue but must be
fixed for this special floating window.
Comment 6 syzygy 2010-06-08 13:05:28 UTC
Maybe 3.3? This problem is an inconvenience when a set of formulas and using 
other applications OOo
Comment 7 thomas.lange 2010-06-08 13:28:09 UTC
tl->kpalagin: let's try and see with the 3.3 target.
Comment 8 thomas.lange 2010-07-02 09:36:13 UTC
.
Comment 9 thomas.lange 2010-08-20 13:58:02 UTC
It wasn't a problem with the c-tor (it didn't get called again) but with the
StateChanged method where the first category was always set.

Fixed in CWS tl82.
Comment 10 thomas.lange 2010-09-13 08:12:29 UTC
.
Comment 11 eric.savary 2010-09-16 11:04:58 UTC
Verified in CWS tl82
Comment 12 michael.ruess 2010-10-14 11:28:06 UTC
Checked in DEV300m89.