Issue 8637 - Trouble with hyperlinks in Presentations
Summary: Trouble with hyperlinks in Presentations
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.1
Hardware: PC Windows 2000
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: christian.guenther
QA Contact: issues@graphics
URL:
Keywords: oooqa
: 8809 (view as issue list)
Depends on:
Blocks:
 
Reported: 2002-10-23 11:19 UTC by cbelch
Modified: 2013-08-07 15:20 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
PPT with HyperLinks (14.50 KB, text/plain)
2002-10-25 10:30 UTC, cbelch
no flags Details
SXI with HyperLinks (8.94 KB, text/plain)
2002-10-25 10:30 UTC, cbelch
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description cbelch 2002-10-23 11:19:04 UTC
I have a MS PowerPoint presentation which has hyperlinks to both Documents 
(link to PDF file) and Slide Numbers (link on slide 1 that takes you to slide 
5).  When I run the presentation via Open Office Impress the hyperlinks to 
Documents dosent work!  The links to slides are fine!

Also there does not seem to be a way in which I can edit the hyperlink details 
(I click on the hyperlink diolgue box and no data is present).

I also created a new presentation within Open Office (sxi format).  I inserted 
hyperlinks but they did not work when I ran the show!  When converted to ppt 
format the links where lost even on slide view!
Comment 1 prgmgr 2002-10-25 03:43:44 UTC
Cheryl, thank you for using and supporting OOo.

One problem per issue please.

In regards to your first problem, please post a small PowerPoint 
presentation that reproduces the problem you mentioned.
Comment 2 cbelch 2002-10-25 10:29:14 UTC
Thank you for the response ....

I have created 2 presentations

1. A powerpoint presentation with 3 slides.  On slide 1 I inserted a 
link directly to slide 3 and a link to our website.  The links seem 
to be ok while in slide view but when I run the slide show the links 
do not work.  I save (.ppt) and close the file.  When the file is 
reopened the links are gone (the text is there but no link).

2. An OpenOffice presentation with 3 slides.  On slide 1 I inserted a 
link directly to slide 3 and a link to our website.  The links seem 
to be ok while in slide view but when I run the slide show the links 
do not work.  I save (.sxi) and close the file.  When the file is 
reopened the link to slide 3 does not work (not even in slide view).
Comment 3 cbelch 2002-10-25 10:30:11 UTC
Created attachment 3345 [details]
PPT with HyperLinks
Comment 4 cbelch 2002-10-25 10:30:37 UTC
Created attachment 3346 [details]
SXI with HyperLinks
Comment 5 prgmgr 2002-10-27 17:57:49 UTC
Cheryl, did you create the PowerPoint presentation in OOo or 
PowerPoint?
Comment 6 cbelch 2002-10-28 09:12:40 UTC
Both presentations were created in OpenOffice.  One saved as .ppt and 
one saved as .sxi.

Thanks,
Cheryl ;o)
Comment 7 prgmgr 2002-10-30 02:18:38 UTC
*** Issue 8809 has been marked as a duplicate of this issue. ***
Comment 8 wolframgarten 2002-11-06 08:06:34 UTC
Reassigned to Christian.
Comment 9 prgmgr 2002-11-10 15:56:15 UTC
Cheryl, turns out this is a known issue.

Please see issue 2224

*** This issue has been marked as a duplicate of 2224 ***
Comment 10 christian.guenther 2003-01-28 09:57:46 UTC
changed the target.
Comment 11 christian.guenther 2003-02-05 17:20:21 UTC
There are 3 different bugs in this issue. Only one is duplicate to
issue 2224. I reopen the issue.
Comment 12 christian.guenther 2003-02-05 17:20:43 UTC
Set to new
Comment 13 christian.guenther 2003-02-05 17:26:21 UTC
I can reproduce the part with the broken internal link after saving
and reloading the document.

I can also reproduce the dissapeared links after saving as a PPT file.

Only the bug that the hyperlinks not work in the running presentation
is duplicate to issue 2224

Reassign the issue to sj.

Cheryl
you wrote 3 different bugs in one Issue. Please create one issue for
each bug in the future.
Comment 14 sven.jacobi 2003-02-14 10:31:29 UTC
SJ->CGU: In the latest developer build there seems to be no error in 
the PowerPoint filter. Can you please verify this and maybe split up 
the remaining problems of this bug into belonging together pieces and 
send this to the proper developer, thanks.
Comment 15 christian.guenther 2003-03-06 14:56:21 UTC
The part with the dissapeared external links is fixed in the internal
version but not in the OOo version. mho have a look why the fix is not
in the OOo version.
Comment 16 christian.guenther 2003-03-06 15:43:11 UTC
After examine the issue only one bug still occure. I've written a new
issue about this bug (issue 12101) and close this issue.
Comment 17 christian.guenther 2003-03-06 15:44:11 UTC
I close this issue.