Issue 86428 - Field "page number" changes value when printing selection
Summary: Field "page number" changes value when printing selection
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: printing (show other issues)
Version: OOo 2.3
Hardware: All All
: P3 Trivial (vote)
Target Milestone: 4.0.1
Assignee: mikhail.voytenko
QA Contact:
URL:
Keywords: needhelp, oooqa
Depends on:
Blocks:
 
Reported: 2008-02-25 10:59 UTC by finngruwierlarsen
Modified: 2017-05-20 10:34 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description finngruwierlarsen 2008-02-25 10:59:37 UTC
When you mark a selection of the document and choose File > Print > Selection,
the printed page numbers are changed so that they will start with 1 on the first
printed page.
Comment 1 michael.ruess 2008-02-25 13:13:13 UTC
Reassigned to HI.
Comment 2 Rainer Bielefeld 2008-02-25 18:04:59 UTC
I checked with "2.0.2  German version WIN XP: [680m5(Build9011)]" and can
confirm the reported effect. Additionally I found out:

This is not a special WRITER effect, I also see it in CALC.
In WRITER I always see that the field will show "Page 1" for the first page of
my selection.

Same effect for "Export to PDF".

Same effect for field in footer or text body.

No idea whether that is "Function as designed" or a real BUG.
<http://specs.openoffice.org/writer/extensions/InsertPagination.odt> seems not
to contain information concerning this problem. 

Related to Wontfix Issue 27629?
Comment 3 Rainer Bielefeld 2008-08-09 17:10:59 UTC
I still see this with "Ooo-dev 3.0.0 Beta Multilingual version German UI WIN XP:
[300m29 (Build9339)]".

Still no idea whether bug or feature!
Comment 4 h.ilter 2008-08-12 15:28:17 UTC
Seems to be framework related. Please have a look.
Comment 5 Rainer Bielefeld 2013-10-11 04:49:57 UTC
Reproducible with "Ooo 2.0.3 [680m5 (Build 9011)]" German WIN7  Home Premium  (64bit) 

Additional info:
----------------
(a) Also field "Number of pages is affected.
(b) I think that's a bug, not a feature. After having read the Help text 
    everybody will expect the field "page number" to show the page number of the 
    page in the document, not the page number in printout.
(c) Still reproducible with OOo 3.1.1, OOo 3.3.0 (changed field contents
    already visible in print preview)
(d) fixed in AOO 3.4.0,  but because of crippled Target Milestone selector 
   (Bug 123063) I only can select TM = 4.0.1 or 4.1.0, no useful information 
   can be left.