Issue 86768 - List Paragraph has wrong style after saving odt
Summary: List Paragraph has wrong style after saving odt
Status: CLOSED DUPLICATE of issue 87808
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOo 2.4 RC2
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: andreas.martens
QA Contact: issues@sw
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2008-03-06 12:58 UTC by jbf.faure
Modified: 2013-08-07 14:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
file produced with OOo 2.3 (15.65 KB, application/vnd.oasis.opendocument.text)
2008-03-06 13:01 UTC, jbf.faure
no flags Details
file OK (70.88 KB, application/pdf)
2008-03-06 13:02 UTC, jbf.faure
no flags Details
file no OK (99.07 KB, application/pdf)
2008-03-06 13:03 UTC, jbf.faure
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jbf.faure 2008-03-06 12:58:25 UTC
Steps to reproduce :
- open ControleGrosOeuvre-Etancheite2007-2008.odt file with OOo 2.4 RC2 FR
- File > Save as "newName.odt" (or modify the doc and save)
- close the file
- open newName.odt (reopen the same file)
look at the first paragraph after title "TRAVAIL DEMLANDÉ" ,it looks like 
ControleGrosOeuvre-Etancheite2007-2008-testOOo2.4rc2_JBF3.pdf instead of 
ControleGrosOeuvre-Etancheite2007-2008.pdf
Comment 1 jbf.faure 2008-03-06 13:01:19 UTC
Created attachment 51934 [details]
file produced with OOo 2.3
Comment 2 jbf.faure 2008-03-06 13:02:32 UTC
Created attachment 51935 [details]
file OK
Comment 3 jbf.faure 2008-03-06 13:03:36 UTC
Created attachment 51936 [details]
file no OK
Comment 4 jbf.faure 2008-03-06 13:07:50 UTC
As mentionned in file description, original file has been done with OOo 2.3

The problem has been reproduced under Kubuntu 6.06 FR and Ubuntu 7.10
Of course Bitstream Vera Sans is installed.
Comment 5 michael.ruess 2008-03-06 15:10:02 UTC
This is not a problem of the font replacement. The paragraph has now style
"Default" instead of "Text body".

MRU->AMA/OD: open attached document and save it, reopen -> the paragraph "Sur un
ou plusieurs..." is now formatted with "Default" style, not with "Text Body" as
it is the case in the original file. In the content.xml I can see, that in the
new copy of the file "<text:p text:style-name="P15">" is missing for the
mentioned paragraph in contrast to the original.
I also do not know, if it matters that the paragraph is part of a list, so I put
OD onto cc of this issue.
Comment 6 andreas.martens 2008-05-27 16:11:03 UTC
Duplicate to already fixed issue 87808

*** This issue has been marked as a duplicate of 87808 ***
Comment 7 jbf.faure 2008-06-28 12:09:14 UTC
works well in OOo 2.4.1.