Issue 86770 - Query Data via NotesSQL (ODBC) causes OOo and Lotus Notes crashes (worked on OOo 1.1.5)
Summary: Query Data via NotesSQL (ODBC) causes OOo and Lotus Notes crashes (worked on ...
Status: UNCONFIRMED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.3.1
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needhelp, needmoreinfo
Depends on:
Blocks:
 
Reported: 2008-03-06 14:27 UTC by bow_edv
Modified: 2013-02-07 22:34 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Log File (296.10 KB, text/plain)
2008-03-06 14:32 UTC, bow_edv
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description bow_edv 2008-03-06 14:27:38 UTC
OOo 2.0 - OOo 2.3.1
Lotus Notes 6.5.3
NotesSQL ODBC driver (e.g. 8)
Windows XP Professional, Version 2002, SP2

I try to connect Lotus Notes Databases (.nsf - Files) as datasource for OOo
using the "NotesSQL" ODBC driver (I have to provide our users addresses, etc.
for handling serial letters). 

In later Versions (e.g. 1.1.5) this worked fine; I had to connect the datasource
directly in the serial letter workflow within OOo Writer.

Since OOo 2.x I have to declare the datasource as OOo-Base- (ODBC-) Datasource.
 - installing the ODBC driver, 
 - defining and testing the ODBC-Connection using the Windows ODBC-Manager, 
 - declaring a new "database" based on ODBC with OOo Base
works fine.
Base is now listing the existing "tables"
Even opening a table by "Edit" works and displays the data fields of the table

In the moment I try to query data (double click at a table in Base; Datasource
browser in Writer) Notes and OOo crash:

the system provides a PopUp:
"NSD Is Running  /  Saving to file 
D\notes\data\........log  /   This file may be used by your company's held 
desk and IBM to determine the possible cause of this error ..... "
it is most likely that this is caused by a (partial) crash of Notes.

a second popup (OOo) tells me, that "No Resultset was produced".

Clicking "OK" is leading to the crash of OOo and Notes.

I even tried some suggestions I got by visiting OOo-staff at the CEBIT Computer
trade fair:
 - Updating Java to the latest verion (V6 Update 5)
 - Using the latest version of the ODBC driver (V8)

Now I try the last suggestion: write an issue ...
Comment 1 bow_edv 2008-03-06 14:32:18 UTC
Created attachment 51938 [details]
Log File
Comment 2 bow_edv 2008-07-10 08:27:42 UTC
Hello there!

is there anybody looking after Issue 86770?
I posted it on March, 6. 2008 an ther isn't any comment or even change of state.

Please, could you take a look?

Many thanks,


Marcus Hoffmann

*******************************************************
Bischöfliches Ordinariat Würzburg
Stv. Leiter EDV-Stelle
Domerschulstr. 2
97070 Würzburg

Tel.: +49 - (0)931 - 386 538
Fax: +49 - (0)931 - 386 467
Mail marcus.hoffmann@bistum-wuerzburg.de
*******************************************************
Comment 3 Mechtilde 2008-07-10 09:23:08 UTC
I don't know if anyone here also use NotesSQL to confirm  this problem.

Is it a free database management system so I can download it for testing?
Comment 4 christoph.lukasiak 2008-08-11 14:44:34 UTC
is this issue still valid -> does it still occure in a curent version

can anyone confirm that behavior?

thx
Comment 5 christoph.lukasiak 2008-09-01 15:16:46 UTC
no respond
Comment 6 christoph.lukasiak 2008-09-01 15:17:11 UTC
close
Comment 7 christoph.lukasiak 2009-06-15 12:08:29 UTC
reopen (because of mail from Marcus Hoffmann)
he wrote:
1) Yes, I always have problems with that connection; they differ a little bit
since Notes 8.5 (various behavier: sometimes crash / sometimes empty datasets:
rownum seems correct, but no data in colums / sometimes no answer at all …), but
fact is, that the connection doesn’t work as it did on OOo 1.1.5.

I tested with 2.4, 3.0 and 3.1

With 1.1.x, everything works fine; but I can’t tell users to have two or more
versions of OOo to handle side by side …

 

2) Yes, NotesSQL is freeware; it is the IBM odbc database driver for Lotus Notes.

There are versions for Notes < 8.0 and one for Notes 8.x

Comment 8 bow_edv 2009-06-15 12:57:32 UTC
Thank you for re-opening that issue!

Additional information:

Lotus Notes 
 - 8.5 (also tested with Lotus Notes 6.5)

ODBC
 - NotesSQL 8.0 (ODBC Driver for Domino, Release 8.0) for use with Notes 8.x
   -> Attachement
 - former Version: NotesSQL 3.02j for use with every Notes version except 8.x

My system:
 - Win XP
 - LotusNotes 8.5
 - NotesSQL 8.0
 - OOo 3.01 (also tested with 3.1)

Tests:
 - ODBC-Connect (DSN) to Notes, Win XP: o.k.
 - create an ODB on this DSN: o.k.
 - view structure (tables, columnames, ...): o.k.
 - view table (click on table_name) -> Notes crashes
 - query data: sometimes result of x rows, but only empty fields; sometimes the
query never ends, sometimes OOo crashes or Notes crashes.

Test with MS Access 2003:
-> it works
Comment 9 bow_edv 2009-08-18 08:31:34 UTC
With help from fs there is a n analysis and solution for that problem.
Look at issue 63415 for more information.
Comment 10 Frank Schönheit 2009-08-18 08:45:12 UTC
for the record: I could not reproduce the crash at all, but the empty text
fields (which is issue 63415, and fixed for 3.2).
Comment 11 Rob Weir 2013-02-02 02:54:43 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.