Issue 86894 - Cell range selection not highlighted when pasted - approved
Summary: Cell range selection not highlighted when pasted - approved
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOH680m9
Hardware: All Linux, all
: P2 Trivial (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords: regression
: 88244 (view as issue list)
Depends on:
Blocks: 88258
  Show dependency tree
 
Reported: 2008-03-11 01:16 UTC by kyoshida
Modified: 2013-08-07 15:14 UTC (History)
1 user (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
simple change to fix this regression (1.90 KB, patch)
2008-03-11 19:52 UTC, kyoshida
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description kyoshida 2008-03-11 01:16:16 UTC
When pasting a cell range, Calc no longer highlights the pasted range even
though the cell range is logically selected.

Steps to reproduce:

1. Select A1:C3, and press Ctrl-C.
2. Move the cursor to D5.
3. Press Ctrl-V.

The cell range gets pasted, but the range is not highlighted.  Note that even in
this circumstance, the bottom-right marker is displayed & the subsequent ENTER
key presses navigates the cell cursor within the pasted range.

I've tested this using OOH680 m10.
Comment 1 kyoshida 2008-03-11 01:18:36 UTC
I think this should be fixed for 2.4.  It's a regression.
Comment 2 niklas.nebel 2008-03-11 10:01:58 UTC
For 2.4 we only include blocker issues as determined by the release status
meeting. I don't think we have to further delay the release because of this issue.
Comment 3 kyoshida 2008-03-11 19:52:20 UTC
Created attachment 52038 [details]
simple change to fix this regression
Comment 4 kyoshida 2008-03-11 19:54:35 UTC
I cherry-picked from calcselection the minimum change necessary to fix this
regression.  Changing the issue type to PATCH.
Comment 5 pavel 2008-03-13 20:43:53 UTC
Move target.

Comment 6 kyoshida 2008-03-13 20:56:53 UTC
@pjanik: this one is only relevant to 2.4.  3.0 doesn't suffer from this
regression.  So, the target should change to 2.4.1 which doesn't exist yet.
Comment 7 kyoshida 2008-03-13 21:58:27 UTC
setting target back to 2.4.  Please reset target to 2.4.1 once that target
number becomes available.
Comment 8 Martin Hollmichel 2008-03-14 20:06:15 UTC
at this stage of release I suggest to choose target 2.4.1 for this.

@nn: can you please review the suggested fix
Comment 9 ooo 2008-03-17 14:13:04 UTC
Niklas is on vacation. To me the patch looks viable, but I'm not familiar with
the selection overlay and whether calling an update during cut/paste might be
harmful.
Comment 10 bettina.haberer 2008-04-07 14:22:41 UTC
Set keyword regression.
Comment 11 uwe.luebbers 2008-04-29 13:18:30 UTC
added "approved" to the title, because it will be easier to work with the 2.4.1 meta issue 
during release status meetings.
Comment 12 niklas.nebel 2008-04-29 18:52:16 UTC
I committed this to CWS "pasteselection". I also added the corresponding call
for "Find all" (issue 88244, caused by the same change).
Comment 13 niklas.nebel 2008-04-29 18:54:08 UTC
*** Issue 88244 has been marked as a duplicate of this issue. ***
Comment 14 niklas.nebel 2008-04-30 09:39:02 UTC
reassigning to QA for verification
Comment 15 oc 2008-05-06 08:42:14 UTC
verified in internal build cws_pasteselection
Comment 16 oc 2008-09-19 10:28:58 UTC
closed because fix available in OOo2.4.1