Issue 87039 - Chart metafile: text moves on Modify > Break
Summary: Chart metafile: text moves on Modify > Break
Status: CLOSED FIXED
Alias: None
Product: Draw
Classification: Application
Component: editing (show other issues)
Version: OOo 2.4 RC4
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: clippka
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-14 18:59 UTC by Joe Smith
Modified: 2017-05-20 10:35 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Sample drawing demonstrating the problem (50.34 KB, application/vnd.oasis.opendocument.graphics)
2008-03-14 19:02 UTC, Joe Smith
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Joe Smith 2008-03-14 18:59:34 UTC
It is sometimes necessary to make manual adjustments to a chart object. For
this, it is useful to copy the chart object, then paste special as "GDI Metafile".

The resulting metafile cannot be edited unless it is first processed by the
Modify > Break operation.

Unfortunately, the "Break" causes all of the text elements from the chart to
shift. Their positions have to be adjusted manually to restore the proper
appearance.

This may be the same as Issue 76317, but I wanted to file something specific to
working with a chart.
Comment 1 Joe Smith 2008-03-14 19:02:05 UTC
Created attachment 52104 [details]
Sample drawing demonstrating the problem
Comment 2 christian.guenther 2008-03-18 11:28:08 UTC
Set to new and change the target.
Comment 3 christian.guenther 2008-03-18 11:32:00 UTC
I can reproduce the bug in dev300m3.
Comment 4 dimitri 2008-05-09 09:07:52 UTC
Issue 75928 "Separating a group imported from DXF distorts the drawing" is 
most probably a duplicate of this issue; and Issue 964.  And it is only 
partially fixed in the current OOo 3.x beta (BEA300_m2).

The following needs to be done for each and every text objects after a 
metafile is separated/broken down, in order to get a manageable drawing:

Format -> Character -> Position -> Spacing -> Default (0.0pt) - 4 clicks

Format -> Text -> Uncheck "Fit to frame", check "Fit width to text", 
check "Fit height to text", set "Spacing to borders (Left, Right, Top, 
Bottom)" to zero. - 9 clicks, 4 selections

What's worse, these attributes cannot be set by selecting the entire drawing, 
and a macro cannot be recorded.
Comment 5 dimitri 2008-07-16 14:16:25 UTC
A quicker workaround that may work for you:

Select the metafile.
Modify > Break
Edit > Select All (Ctrl/A)
Format -> Text -> Uncheck "Fit to frame"
Set Spacing to Borders to something other than 0.00, let's say 1, and press OK
Make sure all elements are still selected
Format -> Text -> Uncheck "Fit to frame"
Set Spacing to Borders to 0 and press OK.



Comment 6 Joe Smith 2014-04-17 23:09:34 UTC
Testing AOO 4.1 beta on Fedora Linux

There are other problems with pasted charts but the text positions are stable--this problem seems to have been fixed.

Closing.