Issue 87104 - Mailmerge is too slow
Summary: Mailmerge is too slow
Status: CLOSED DUPLICATE of issue 40827
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: DEV300m5
Hardware: PC Windows XP
: P4 Trivial with 7 votes (vote)
Target Milestone: ---
Assignee: Oliver Specht
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-17 01:06 UTC by mfn
Modified: 2009-07-12 17:56 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description mfn 2008-03-17 01:06:36 UTC
Hi,

I know that DEV300m3 is a Beta version and that the development has just started
and I know that the Issue is yet reported [1][2], but I think its important to
fix this performance problem in OOo 3.0.
Because compared to MS Office 2007, OpenOffice needs 10 to 60 times the time
that Word needs to personalize the documents.

I tested with 350 Recipients 
   -OpenOffice approx. 30 minutes to personalize 
   -MS Office 2007 less than a minute

and 54 Recipients on a AMD 2600+ with 2GB RAM
   -OpenOffice approx. 3 minutes 
   -MS Office 2007 approx. 10 seconds

I took a look at the code, but I can't explain why it is so slow and why it gets
slower with more recipients, perhaps someone else with more UNO experience could
fix it.

[1]http://www.openoffice.org/issues/show_bug.cgi?id=40827
[2]http://www.openoffice.org/issues/show_bug.cgi?id=54531
Comment 1 michael.ruess 2008-03-17 10:02:17 UTC
Reassigned to HI.
Comment 2 h.ilter 2008-03-18 15:32:17 UTC
HI->OS: I've got 40sec. for 300 recipients. 
One page text only doc.
Comment 3 mfn 2008-03-18 19:48:35 UTC
Tried it again with 378 Recipients, took 8:54 min to personalize and 1:47 to
save the document.

Screenshot http://s1.directupload.net/file/d/1371/kzk7ax7j_png.htm 

The document has 2 pages and is based on the letter Template of the Technical
University of Darmstadt. I put the template on
http://www.outsch.org/tud_template.dot. The Fonts in this template were
purchased by the TUD and are not available for public, so they should be replaced.

I think I know why it's faster now. If I remember correctly, I had only 1GB RAM
when I tested it with 350 Recipients, after that experience I decided to switch
to Word for Mail Merge. But also with 2GB its 13.35 times slower than on your
machine.

My PC: AMD Athlon XP 2600+, 2GB RAM, 1GB Swap, 100+GB HDD, Windows XP Service
Pack 2 with all Updates.

Perhaps it's caused by a misconfiguration? I didn't change anything in bei
DEV300M3 Installation.
Comment 4 aladdin2k7 2008-04-07 11:03:00 UTC
First of all, check your mailmerge result : if there is 350 page styles,try to
format your document with no header and no footer otherwise OOo will create 
a new page style for each records.

I wonder why if I use Default page style with header and footer activate, OOo
will create for each record a new page style ? (Default1, Default2, Default3 ...
Default350)


Comment 5 aladdin2k7 2008-04-08 08:55:53 UTC
Ok right for header/footer content but we will have some perfomance issue when
you have to enable it and you have a lot of record (about 1000).
Comment 6 mfn 2008-04-10 19:54:39 UTC
Tested it with DEV300_m5 still slow.
I understand the header/footer Problem, but why there is no effect in MS Office?
How is this Problem solved by Microsoft? Any Idea?
Comment 7 cno 2008-05-08 10:42:53 UTC
Hi,
Any news on this? I have to kill my office-process when trying a merge with more
then few hundred addresses ...
Comment 8 cno 2008-06-11 08:02:50 UTC
I did some performance tests.

- Text document with one single page, one graphic, 5 fields, one conditional
paragraph;
- A database with 945 records

Results on test system with 2.5 Mhz / 2 Gig (*)

OOo 		Time
2.1		04:05
2.2.1		03:49
2.3.1		04:30
2.4.1		05:17
3.0Beta1	05:48
	
System with 1.6 Mhz / 1 Gig (* / **)
	
2.4.1		11:29

*) of course all tests with only the used version of OOo in memory
**) when doing my daily work on this laptop, memory is of course used by other
programs as well
Comment 9 aladdin2k7 2008-06-11 08:36:34 UTC
There is an overview of the problem here :
http://wiki.services.openoffice.org/wiki/OOo_3_Beta_feedback

"polish up mailmerge and mailmerge perfomance : 40827 54531 87104"
Comment 10 djerome62 2008-12-08 14:39:03 UTC
Bonjour

Pourriez-vous faire pour que l'on puisse d'abord sélectionner les fiches à
fusionner lors de l'assistant, plutôt que de créer en mémoire l'ensemble des
fiches fusionnées et seulement après effectuer la sélection.

Cela permettrait de réduire le temps de la fusion et les ressources machine.

En vous remerciant par avance.
Comment 11 Oliver Specht 2008-12-09 14:07:19 UTC
Duplicate

*** This issue has been marked as a duplicate of 40827 ***
Comment 12 Mechtilde 2009-07-12 17:56:32 UTC
duplicate -> closed