Issue 87105 - Write Error on export to Microsoft Excel 2003 XML format
Summary: Write Error on export to Microsoft Excel 2003 XML format
Alias: None
Product: Calc
Classification: Application
Component: save-export (show other issues)
Version: OOo 2.4 RC5
Hardware: All All
: P3 Trivial with 9 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
: 94787 96005 (view as issue list)
Depends on:
Reported: 2008-03-17 01:45 UTC by ccheney
Modified: 2013-08-07 15:14 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

example file (14.60 KB, application/vnd.oasis.opendocument.spreadsheet)
2008-03-17 01:45 UTC, ccheney
no flags Details
example file - "don't save as xml.ods" & "save as xml.ods" (12.04 KB, application/x-compressed)
2010-08-26 14:21 UTC, nipfoth
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description ccheney 2008-03-17 01:45:01 UTC
Exporting this ods file to Microsoft Excel 2003 XML format causes this error
message to pop up.

Error saving the document kacer_0208:
Write Error.
The file could not be written.
Comment 1 ccheney 2008-03-17 01:45:49 UTC
Created attachment 52140 [details]
example file
Comment 2 oc 2008-03-17 09:36:37 UTC
Comment 3 jurino 2008-03-27 13:55:00 UTC
On 2.2.1 it runs fine, 2.3 and 2.4 are affected.
Comment 4 svante.schubert 2008-04-03 14:06:12 UTC
There is somewhere a endless loop, I activated the debug:
Under toolbar - OPTIONS - JAVA EnvironmentVariable add, e.g.


And the output will be written into the file.
Someone have to take a look into it, usually the transformation works standalone
as well, when instead of the ZIP the FLAT XML file is being used as input.

more information about this can be found on the xml dev mailinglist.

Furthermore, by adding some notes xsl:message into the source code or using an
XSLT debugger the issue can be found.

The Excel2003 filter is unfortunately no longer on my prio list, as OOXML has
become its successor, somebody else have to help out.

Thanks for pointing out the problem, nevertheless..
Comment 5 husakf 2008-05-08 22:23:25 UTC
I've tried to save the ods file in the 2003 XML format and it still doesn't work
(OO 3.0 beta) :(. 
Comment 6 svante.schubert 2008-05-30 14:46:44 UTC
I am sorry, I am no longer working on this format.
Changed target to Office later.
Is anybody able to take this over? And/or provide a patch for this problem?

Thanks in advance,
Comment 7 jsnellings 2008-10-29 12:27:26 UTC
Just tested it on OpenOffice production version and it still does not work.
Endless loop.
Comment 8 svante.schubert 2008-10-31 16:50:16 UTC
We need someone of the community to take this over!
Any volunteers?
Comment 9 Regina Henschel 2008-11-09 19:01:48 UTC
The error is triggerd, when there are some empty rows which has to be
considered. In detail:

When you have 3 and more empty rows between to entries:


or when you have 4 and more empty rows after entries, which have a formatting
like borders or background color and therefore have to be considered.

In the example file there are the empty rows 23 to 47 with borders. Delete this
rows and the file will save to Excel 2003 XML format.
Comment 10 Regina Henschel 2008-11-09 19:04:39 UTC
*** Issue 94787 has been marked as a duplicate of this issue. ***
Comment 11 Regina Henschel 2008-11-09 19:09:14 UTC
*** Issue 96005 has been marked as a duplicate of this issue. ***
Comment 12 ttwhy 2008-12-16 16:30:20 UTC
Bug still exists in version 3.0 of OpenOffice. Microsoft Excel 2003 XML export
is only rarely usable.
Comment 13 svante.schubert 2008-12-16 16:37:54 UTC
Yes, we need a developer, who will contribute his work on this.
The status is set to "OOo PleaseHelp"..

Comment 14 ccheney 2009-03-03 03:29:17 UTC
This appears to probably be the xalan 2.7.1 issue also referenced here:

And here:<7365434.1201876156390.JavaMail.jira@brutus>
Comment 15 ccheney 2009-03-18 20:07:36 UTC
Sorry after more research this is almost certainly not the xalan issue I
mentioned before...
Comment 16 ccheney 2009-03-20 16:45:47 UTC
I believe this issue is probably caused by using system saxon, the internal
saxon has patches to it that allow it to work with the stylesheets in OOo. There
should be a configure warning to warn users not to build with system saxon until
the patches have been integrated upstream and/or convert the OOo xsl stylesheets
to XSLT 2.0 which would probably also resolve this problem.
Comment 17 madz__ 2009-09-02 21:50:24 UTC
I have the same issues even in ooO-dev 3.2
someone, fix it please
Comment 18 zlolik 2009-10-16 09:57:58 UTC
I reported about same issue on
On ubuntu 9.04 i found the solution good for me:
1. Remove all openoffice* and sun-java* packages.
2. Go to the site
3. Choose "Include the Java JRE ..."
4. Download version suitable for me:
(Russian 3.1.1) (Linux 32-bit DEB)
5. Unpack downloaded file
6. Launch file update in unpacked directory
Hope, this helps somebody.
Comment 19 nipfoth 2010-08-26 14:21:25 UTC
Created attachment 71412 [details]
example file - "don't save as xml.ods" & "save as xml.ods"
Comment 20 nipfoth 2010-08-26 14:22:33 UTC
Does not save to xml if cell A1 is empty and data is scattered on the sheet. For 
example file: save to xml “save as xml.ods” and does not save to xml “don't save 
as xml.ods”.