Issue 87265 - Graphics inside and anchored to cells do not behave in predictable ways
Summary: Graphics inside and anchored to cells do not behave in predictable ways
Status: CLOSED DUPLICATE of issue 11827
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: OOo 2.3.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2008-03-19 20:46 UTC by sgolux
Modified: 2010-06-22 17:08 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description sgolux 2008-03-19 20:46:24 UTC
1.  Create a spreadsheet with several rows and several columns.

2.  In one of the columns, in most (or all) rows) place some graphics you have
used CALC to create.  Make sure these graphics are anchored to the cell, not the
page.

3.  Select the entire spreadsheet.

4.  Sort the spreadsheet based on non-graphic data in columns in which you have
NOT placed any graphics.

5.  The graphics have not been sorted properly with the rows according to the
cells in which they are anchored.

ADDITIONAL INFORMATION:

It is also the case that if you Delete Rows, the columns that have graphics get
"messed up" in ways that are not predictable, and which I can't really
characterize because I have not found a pattern.  However, if you delete all the
data (including graphics) in a given row, and THEN delete the row, the
surrounding graphics seem to be handled correctly.

In the mailing lists, some users have postulated that the graphics when anchored
to a cell is actually anchored to the absolute cell reference, and not the cell
contents in a way that would make it make sense to be able to sort and so forth.
 I would maintain that this makes it not very useful, and at the very least,
there ought to be a way to choose to either anchor it to the absolute cell
reference, or to the contents of a cell.  (Especially since text and numerical
data can, in fact, exist in the same cell with some graphics anchored there, but
the two will be handled very differently as the spreadsheet gets manipulated.)
Comment 1 amy2008 2008-09-02 06:11:24 UTC
Can reproduce it in OOo300_m3_EN on WinXP.
Comment 2 amy2008 2008-09-02 06:12:10 UTC
Confirmed
Comment 3 frank 2008-09-02 10:10:47 UTC
isn't it Issue 11827, is it ?
Comment 4 Regina Henschel 2010-06-22 17:08:17 UTC
Yes. Same problem as in issue 11827. Issue 11827 has got more votes, so I close
this one. Please move your votes.

*** This issue has been marked as a duplicate of 11827 ***
Comment 5 Regina Henschel 2010-06-22 17:08:42 UTC
closing, duplicate.