Issue 87420 - Applying "Default Formatting" should not remove Character Styles
Summary: Applying "Default Formatting" should not remove Character Styles
Status: CLOSED DUPLICATE of issue 47893
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.3
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-25 16:00 UTC by linqi
Modified: 2008-03-26 11:57 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description linqi 2008-03-25 16:00:21 UTC
I applied "Text body " paragraph style to a paragraph. Then I selected one word
in that paragraph, and applied a Character Style (say, Strong Emphasis) from
"Character Styles" dialog.

I manually selected the whole paragraph and changed font size of that paragraph.
And I selected some text and manually changed some formats (using Bold, Italic,
Underline, etc, but not applying character styles).

After that I want to remove all manually applied formats, so I selected whole
paragraph, and right-clicked on it, then chose "Default Formatting". The result
was only "Text body" paragraph style (and its formats) retained, all manually
applied formats removed, so as "Character Styles".

Therefore the right-clicked popup menu "Default Formatting" should be renamed to
"Remove manually applied formats". And the most important one is that the
Character Styles applied in the paragraph should NOT be removed. The styles are
very useful for long document formatting, like FrameMaker, when removing all
manually applied formats, paragraph and character styles are all retained.
Comment 1 michael.ruess 2008-03-26 11:57:18 UTC
Already tracked as issue 47893.

*** This issue has been marked as a duplicate of 47893 ***
Comment 2 michael.ruess 2008-03-26 11:57:54 UTC
Closing duplicate.