Issue 87625 - Import from word 2003 converts westren number to arabic numbers
Summary: Import from word 2003 converts westren number to arabic numbers
Status: CLOSED DUPLICATE of issue 86811
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 2.4.0
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-30 21:48 UTC by kaplanlior
Modified: 2008-08-18 15:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
A word 2003 document with Hebrew alphabet and regular numbers. (19.50 KB, application/msword)
2008-03-30 21:51 UTC, kaplanlior
no flags Details
Test case file opened with Abiword 2.4.6 (56.86 KB, image/png)
2008-03-30 21:52 UTC, kaplanlior
no flags Details
Test case file opened with OO.org 2.4.0~rc6 on Debian Unstable (50.78 KB, image/png)
2008-03-30 21:53 UTC, kaplanlior
no flags Details
Test case file opened with OO.org 2.4.0 on Windows XP (24.88 KB, image/png)
2008-03-30 21:53 UTC, kaplanlior
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kaplanlior 2008-03-30 21:48:14 UTC
1. When importing a word 2003 document I see the number as Arabic numbers.

2. The problem was verified on Debian Unstable with 2.4.0~rc6 and on Windows XP
with 2.4.0.

3. Opening the original word document with Abiword shows numbers correctly (thus
making me think its an OO.org problem).

4. If I save the word document with OO.org, opening it again with abiword indeed
shows Arabic numbers.

A test document and screenshots are attached.
Comment 1 kaplanlior 2008-03-30 21:51:16 UTC
Created attachment 52378 [details]
A word 2003 document with Hebrew alphabet and regular numbers.
Comment 2 kaplanlior 2008-03-30 21:52:20 UTC
Created attachment 52379 [details]
Test case file opened with Abiword 2.4.6
Comment 3 kaplanlior 2008-03-30 21:53:00 UTC
Created attachment 52380 [details]
Test case file opened with OO.org 2.4.0~rc6 on Debian Unstable
Comment 4 kaplanlior 2008-03-30 21:53:33 UTC
Created attachment 52381 [details]
Test case file opened with OO.org 2.4.0 on Windows XP
Comment 5 kaplanlior 2008-03-30 22:04:59 UTC
Opps, seems to be already reported by Nadav. Thanks to Dotan to let me know.
Comment 6 michael.ruess 2008-03-31 09:24:47 UTC
Yep, see issue 86811. Feel free to add your comment or vote there.

*** This issue has been marked as a duplicate of 86811 ***
Comment 7 michael.ruess 2008-03-31 09:25:11 UTC
Closed.
Comment 8 jdpipe 2008-08-18 06:25:00 UTC
Hi there

Wondering this this fix had also been checked with Math objects in OpenOffice
2.4.1. I am still occasionally seeing this bug with OOo 2.4.1 on Ubuntu Hardy in
documents originally imported from MS Word using OOo 2.4.1.

Cheers
JP
Comment 9 michael.ruess 2008-08-18 15:22:28 UTC
In my OO2.4.1 build this works fine. 
JD, do you work with the ubuntu builds or the downloaded version from OOO homepage?