Issue 87650 - restart paragraph numbering on outline headings: lost when reloading file
Summary: restart paragraph numbering on outline headings: lost when reloading file
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.4.0
Hardware: All Windows XP
: P2 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2008-03-31 14:49 UTC by wolf12
Modified: 2013-08-07 14:43 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
open this file in 2.3.1 and 2.4 (12.12 KB, text/plain)
2008-04-01 14:53 UTC, wolf12
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description wolf12 2008-03-31 14:49:07 UTC
paragraph numbering:
 this is a regression from 2.3 and needs a quick fixe

1 first

2 second
now from FORAMT/PARAGRAPH/ numbering
  select restart paragraphe at 1

1 this is the third parapgraphe restarting with number 1

____ now save this file
____ reload this file
____ the restart is lost

1 first

2 second
now from FORAMT/PARAGRAPH/ numbering
  select restart paragraphe at 1

3 this is the third parapgraphe after reload of the file with number 3

-------------------------------------------------------
This basically disables the feature and I have to fall back to rev 2.3
Comment 1 michael.ruess 2008-03-31 16:06:33 UTC
I cannot reproduce the problem with my OO 2.4 on WinXP. Could you please attach
a short document to this issue, which shows the problem? Thanks for your patience.

For setting appropriate Priority of an issue please have a look at
http://www.openoffice.org/scdocs/ddIssues_EnterModify.html#priority
Comment 2 wolf12 2008-04-01 14:53:12 UTC
Created attachment 52438 [details]
open this file in 2.3.1 and 2.4
Comment 3 wolf12 2008-04-01 14:55:13 UTC
see attached file
issue description within

this is NOT resolved, sorry
Comment 4 michael.ruess 2008-04-02 15:52:26 UTC
MRU->OD: the import seems to ignore the "restart numbering" settings on outline
paragraphs ("normal" paragraphs work fine). It is correctly saved in the xml
code, but nit regarded on load.
Comment 5 Oliver-Rainer Wittmann 2008-04-04 12:49:15 UTC
Investigation reveals that this is caused by a serious defect introduced by CWS
swwarnings.
In method <SwXNumberingRules::replaceByIndex(..)> member variable <pNumRule> is
set in case that <pDocSh> is set. Before CWS swwarnings a local variable is
used. Thus the <SwXNumberingRules> instance, which represents the outline style
- <pNumRule> == 0 && <pDocSh != 0>, is morphed to a <SwXNumberingRules> instance
representing a normal list style. The special code for the outline style is no
longer processed after the first call of <SwXNumberingRules::replaceByIndex(..)>

From my point of view this issue should be fixed in OOo 2.4.1
Comment 6 Oliver-Rainer Wittmann 2008-04-21 14:13:42 UTC
fixed in cws sw241bf01 - changed file:
/sw/source/core/unocore/unosett.cxx, 1.51.28.1
Comment 7 Oliver-Rainer Wittmann 2008-04-24 07:44:19 UTC
OD->MRU: checked in internal installation of cws sw241bf01 - please verify.
Comment 8 michael.ruess 2008-05-02 11:50:19 UTC
Verified fix in sw241bf01.
Comment 9 michael.ruess 2008-06-09 15:07:55 UTC
Checked fix in OOH680m17 and DEV300m17.