Issue 87692 - too generous "modified" flags in the bug doc's form moving to the form's insertion row
Summary: too generous "modified" flags in the bug doc's form moving to the form's inse...
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.4.0
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: marc.neumann
QA Contact: issues@dba
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-01 12:35 UTC by Frank Schönheit
Modified: 2009-12-30 01:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
document to reproduce the bug case (13.15 KB, application/vnd.sun.xml.base)
2008-04-01 12:35 UTC, Frank Schönheit
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Frank Schönheit 2008-04-01 12:35:00 UTC
- open the attached database document
- open the contained form for editing ("Edit" in its context menu)
- switch off the design mode
=> the form is "modified", i.e. the "Save Document" button in the toolbar
   is enabled. This is unexpected, since no persistent state of the document
   changed.
- save the form by pressing the "Save Document" button
- focus on of the two above controls
- travel to the form's insertion row via the form navigation toolbar
=> the form document again is marked as modified. Again, this is unexpected.
Comment 1 Frank Schönheit 2008-04-01 12:35:38 UTC
Created attachment 52434 [details]
document to reproduce the bug case
Comment 2 Frank Schönheit 2008-04-01 12:36:04 UTC
targeting
Comment 3 Frank Schönheit 2008-09-07 21:08:05 UTC
*** Issue 93476 has been marked as a duplicate of this issue. ***
Comment 4 Frank Schönheit 2008-09-07 21:31:14 UTC
re-opening issue 93476, which describes the modified-on-design-mode-switch
problem. This issue here will only deal with the modified-on-form-cursor-move
problem. Both have completely different root causes.
Comment 5 Frank Schönheit 2009-03-06 13:43:04 UTC
fixed in CWS dba32b

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba32b
Comment 6 Frank Schönheit 2009-05-07 09:29:18 UTC
fs->msc: please verify in CWS dba32b
Comment 7 Frank Schönheit 2009-05-07 10:57:51 UTC
targeting to 3.2, since the fix is part of a CWS aiming for this release
Comment 8 marc.neumann 2009-05-29 10:13:01 UTC
verified in CWS dba32b, only the record traveling part is fixed as described

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba32b
Comment 9 thorsten.ziehm 2009-07-20 14:54:14 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
http://download.openoffice.org/index.html
If you want to know more about the handling of fixed/verified issues =>
http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues
Comment 10 thorsten.ziehm 2009-07-20 15:35:35 UTC
Sorry this issue was wrongly closed. This issue will be reopened automatically.
And will be set after that back to fixed/verified.
Comment 11 thorsten.ziehm 2009-07-20 15:40:05 UTC
Set to state 'fixed'.
Comment 12 thorsten.ziehm 2009-07-20 15:44:14 UTC
Set back to state 'verified/fixed'.

Again. Sorry for the mass of mails.
Comment 13 drewjensen.inbox 2009-12-30 01:06:55 UTC
verified with OOO320_RC1 / Ubuntu
( verified that 3.1.1 / ubuntu showed the problem, also)

Closing