Issue 87936 - OpenOffice can't open files over ftp if user not anonymous
Summary: OpenOffice can't open files over ftp if user not anonymous
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 3.0
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: tkr
QA Contact: issues@framework
URL: https://bugs.edge.launchpad.net/ubunt...
Keywords:
Depends on:
Blocks: 81913
  Show dependency tree
 
Reported: 2008-04-06 04:24 UTC by ccheney
Modified: 2009-08-02 14:10 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ccheney 2008-04-06 04:24:13 UTC
When trying to open files over ftp using OpenOffice it seems to refuse to work
if the user isn't anonymous, this was initially reported as a bug when using
Gnome gvfs with nautilus but I can reproduce this at the command line with
official version of OpenOffice.

soffice ftp://hostname/foo.odt  - works just fine
soffice ftp://username@hostname/home/username/foo.odt - ask for password then fails
soffice ftp://username:password@hostname/home/username/foo.odt - fails in the
same way

It says the following both cases:

Access to
ftp://username:password@hostname/home/username/foo.odt
was denied.

Access to the same files via a ftp program, wget, or nautilus in Gnome works
fine and the file can later be opened in OOo so it definitely isn't a
permissions problem.
Comment 1 ccheney 2008-12-19 22:31:23 UTC
This bug still occurs with OOo 3.0.0
Comment 2 Martin Hollmichel 2009-04-17 15:30:43 UTC
@kso: please review for feasiblity.
Comment 3 kai.sommerfeld 2009-04-20 08:33:29 UTC
tkr: Please take over. We should fix this for 3.2 (regression).
Comment 4 tkr 2009-04-22 09:28:03 UTC
accepted
Comment 5 tkr 2009-07-22 09:22:33 UTC
https://bugs.edge.launchpad.net/ubuntu/+source/openoffice.org/+bug/36424 was
fixed on 2009-03-20. I also checked it with an ooo (dev300_m53) and an
OpenSolaris. -> worksforme 
 
Comment 6 ccheney 2009-07-26 16:42:02 UTC
This was 'Fixed' in Ubuntu by completely disabling URI parsing in OOo for Ubuntu
since the gnome-vfs and gio support was broken along with ftp, etc. I wrote a
patch for Ubuntu to use gvfs-fuse to work around all the brokenness.
Comment 7 Mechtilde 2009-08-02 14:10:31 UTC
worksforme -> closed