Issue 88144 - [notes2]open word document and directly save to odt
Summary: [notes2]open word document and directly save to odt
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: DEV300m5
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: Mathias_Bauer
QA Contact: issues@sw
URL:
Keywords:
: 89390 90999 91134 91292 (view as issue list)
Depends on:
Blocks:
 
Reported: 2008-04-10 17:01 UTC by max.odendahl
Modified: 2013-08-07 14:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
patch to give correct text in export (2.19 KB, text/plain)
2008-06-23 11:02 UTC, Mathias_Bauer
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description max.odendahl 2008-04-10 17:01:55 UTC
open word document and directly save as an odt document

-> saved notes are all empty

Should SwPostItField::QueryValue( case FIELD_PROP_TEXT: ) somehow return sText
as well, if the textObject is empty?

Would be nice if you could have a look
Comment 1 max.odendahl 2008-05-13 15:37:29 UTC
*** Issue 89390 has been marked as a duplicate of this issue. ***
Comment 2 max.odendahl 2008-06-04 10:06:14 UTC
data loss -> P2
Comment 3 jazzmak 2008-06-11 17:31:48 UTC
I can confirm this is happening with notes2. I hope it will be fixed soon. 
Comment 4 Mathias_Bauer 2008-06-12 12:58:02 UTC
confirmed
Comment 5 jazzmak 2008-06-13 10:05:13 UTC
Postponement of this feature to 3.1 is in conflict with roadmap
http://wiki.services.openoffice.org/wiki/Notes2
which states that notes2 will have funcionality available in current version of 
notes. 
At the moment user who wants to migrate doc documents with commnets to odt have 
to use two version of OpenOffice simultaneosly. 2.4 to make conversion and 3.0 
to actually see and work with the comments.
Is it really suppose to be the case with the highly expected notes2 & 
OpenOffice 3.0?
Comment 6 Mathias_Bauer 2008-06-13 13:52:31 UTC
Sorry, I accidently chose the wrong target, of course it should be 3.0.
Comment 7 Mathias_Bauer 2008-06-23 11:02:10 UTC
Created attachment 54682 [details]
patch to give correct text in export
Comment 8 Mathias_Bauer 2008-06-23 11:30:33 UTC
fixed in CWS notes6
Comment 9 Mathias_Bauer 2008-06-23 11:38:40 UTC
I said *FIXED* :-)
Comment 10 max.odendahl 2008-06-24 10:19:22 UTC
*** Issue 90999 has been marked as a duplicate of this issue. ***
Comment 11 max.odendahl 2008-06-26 23:33:01 UTC
verified in cws notes6
Comment 12 max.odendahl 2008-06-29 22:44:41 UTC
*** Issue 91134 has been marked as a duplicate of this issue. ***
Comment 13 michael.ruess 2008-07-02 09:50:12 UTC
*** Issue 91292 has been marked as a duplicate of this issue. ***
Comment 14 max.odendahl 2008-07-09 19:20:30 UTC
seen in m23