Issue 88484 - Word Count treats number of paragraph as number of word
Summary: Word Count treats number of paragraph as number of word
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: DEV300m7
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL: http://user.services.openoffice.org/e...
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-20 00:05 UTC by lovenemesis
Modified: 2013-08-07 14:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Screenshot of "Statistic" window of Writer (155.22 KB, image/png)
2008-04-20 00:07 UTC, lovenemesis
no flags Details
Simple test case (7.81 KB, application/vnd.oasis.opendocument.text)
2008-04-20 22:18 UTC, troodon
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lovenemesis 2008-04-20 00:05:40 UTC
Word Count does not work properly. It treats number of paragraph as number of
word. It happens to all types of the documents, not only ODF. Deleting the user
profile folder does not solve the  problem.
Comment 1 lovenemesis 2008-04-20 00:07:10 UTC
Created attachment 53041 [details]
Screenshot of "Statistic" window of Writer
Comment 2 troodon 2008-04-20 22:18:42 UTC
Created attachment 53057 [details]
Simple test case
Comment 3 troodon 2008-04-20 22:28:45 UTC
Confirming with DEV300m9 on Ubuntu 7.04 (Feisty). Could not reproduce on Windows
Vista.

Steps to reproduce:
- Open the attached testcase.
- Check the word count. It sould say there are 70 words (actually it sould say
72, but that's another issue) and 358 characters.
- Make any change to the document.
- Check again the word count. Now it says there are 4 words (because there are 4
paragraphs) and 360 characters.

More details:
- Save the document.
- Open it with a previous OOo version (I checked with 2.2).
- Check the word count. It's still the wrong one.
- Made any change to the document.
- Check the word count. It has been updated and now it's the correct one.

I think this could be a regression introduced by the chages made for issue 80815
(CWS i18n40, integrated in DEV300m6).
Comment 4 frank.meies 2008-04-21 10:55:19 UTC
fme: Yes, regression from i18n40. I'll take over.
Comment 5 frank.meies 2008-04-21 15:06:03 UTC
fme: Fixed in cws wordcountfix, txtedt.cxx
Comment 6 frank.meies 2008-04-21 15:11:21 UTC
fme->sba: Ready for QA.
Comment 7 stefan.baltzer 2008-04-24 14:07:25 UTC
Verified in CWS wordcountfix.
Comment 8 foobard 2008-04-25 18:15:31 UTC
bug still present in m10 on Linux.

My understand was that OOo used platform-independent code, so I am at a loss to
explain why this bug shows up in Linux but not in Windows.
Comment 9 troodon 2008-04-27 17:41:26 UTC
->foobard

The CWS wordcountfix still hasn't been integrated in any milestone. Until that
moment, all builds will exhibit this issue.
Comment 10 stefan.baltzer 2008-06-13 14:09:58 UTC
SBA: The fix was integrated in DEV300m12.
Verified in DEV300m18. Closing issue.