Issue 88523 - Extensions slow down reaction of (context)menus
Summary: Extensions slow down reaction of (context)menus
Status: CLOSED OBSOLETE
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 3.0 Beta
Hardware: PC Windows Vista
: P3 Trivial with 14 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-21 08:28 UTC by mreiter
Modified: 2019-10-12 17:04 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description mreiter 2008-04-21 08:28:03 UTC
With more than 5 extensions installed, OOo 2.4.0 menus - especially the context
menu in writer - react slowly, with more than 15 extensions installed the delay
until the context menu appears in writer on Vista + SP1 is about 2 sec. In calc
and impress the menus react more quickly, but not as fast as without extensions.

- same problem with OOo 2.4.0 on Vista + SP1 and XP + SP2 (not as bad as under
Vista); tested on 3 PCs (1 Vista + SP1, 2 XP + SP2)
- same problem with portable OOo 2.4.0
- no problem with versions before 2.4.0
- there is no single extension with causes this slow down: with a rising number
of extensions the reaction becomes slower and slower

-> with extension manager opened and "my extensions" expanded OOo 2.4.0 works fine!?
Comment 1 thorsten.martens 2008-04-21 15:11:08 UTC
Not reproducible in a recent OOo3.0 m9build.
Comment 2 mreiter 2008-04-23 09:04:18 UTC
Tested with portable OOo 2.4.0 on a 4th PC (XP + SP1): extensions slow down OOo.

Tested with OOo 3.0 m10 on the XP + SP2 and Vista + SP1 PCs mentioned above:
extensions slow down OOo.
Comment 3 mreiter 2008-04-28 23:14:00 UTC
Same problem with OOo-Dev_BEA300_m1 on four different computers (1 Vista, 3 XP).
Installed extensions from extensions.services.openoffice.org:
Alternative dialog Find & Replace for Writer, Auto Starter for Presentation
documents, BasicAddonBuilder, Bookmarks Menu, CropOOo, Photo album with GUI, Sun
Presentation Minimizer, Sun Report Builder, SVG Import, TestFonts.
Comment 4 mreiter 2008-05-06 09:01:53 UTC
Same Problem with OOo 3.0.0 beta (OOo_3.0.0beta_20080429) on Vista and XP!
Comment 5 mreiter 2008-05-26 14:47:32 UTC
Behavior has changed in OOo DEV300 m14:

The performance problems appear after installing extensions and completely
restarting OOo.

After starting the new extension manager the problem disappears and OOo works
fine even after closing the manager. 
Comment 6 androbi 2009-01-07 13:18:16 UTC
Same Problem in OOo 3.0.0 (OOO300m9, Build:9358) on WIN XP!!!
Comment 7 androbi 2009-05-14 10:34:57 UTC
Still the same problem in OOo 3.1.0 (OOO310m11, Build:9399) on WIN XP !!!
Comment 8 androbi 2009-05-14 11:09:16 UTC
See Issue 101406. It's nearly the same.
Comment 9 vvzh 2009-05-25 09:56:49 UTC
After unintalling and reinstalling each bundled extension I can confirm what 
androbi stated. The problem is not any specific extension but extension count. 
The delay when showing context menu decreases almost linearly after 
uninstalling each bundled extension. Disabling extensions does not shorten this 
delay.

Until the issue is confirmed, the solution seems to write one more extension to 
automaticaly open and close Extension manager on startup :)
Comment 10 mister_x 2009-05-25 12:45:45 UTC
*** Issue 88523 has been confirmed by votes. ***
Comment 11 quzhengxi 2009-09-16 18:01:46 UTC
Zhengxi Qu, 9/16/09, tried to reproduce the problem:
Environment: OOo 3.1.1 (OOO310m19, Build:9420) English Version
OS: Windows Vista Home Premium SP1
Steps:
-Open OOo with Writer,click Tools-Extension Manager-Add
-Select the extension (.oxt) file downloaded from openoffice.org and click open
-Follow the installation instruction and wait until the description of the 
extension appears in the extension manager list
-Continue with the above two steps to install more extension files
-Click on the menus in Writer to see the reaction

I tried to install 20 extensions in OOo 3.1.1, the menus in Writer reacted 
normally as before I installed the 20 extensions (scroll down menus appeared 
immediately after I click on the main menus). I Also tried in Calc, Draw, Math, 
the menus also reacted fine as normal.
Comment 12 mreiter 2009-09-16 21:29:39 UTC
@ Zhengxi Qu
Did you close OOo completely (quickstarter!) after installing the extensions?
The described problem does not appear if the extension manager is opened once
and OOo is not closed completely.
On all three of my PCs (1 x XP+SP3, 2 x Vista+SP2) the problem still appears
with OOo 3.1.1 (German).
Comment 13 quzhengxi 2009-09-18 02:43:14 UTC
@ mreiter

Thank you for your comments.

Yes I closed OOo completely by selecting Exit in the File menu after I 
installed the extensions. Then opened OOo again and tried selecting menus in 
Writer, Calc, Draw and Math. The menus react normally. Then I tried to 
uninstall the extensions - close OOo completely - open OOo - install 
extensions - close OOo completely - open OOo, the problem did not appear.

I also tried on another machine:
Environment: OOo 3.0.0 (OOO300m9, Build:9358) English Version
OS: Windows XP Professional SP3
And followed the steps described above, the menus react fine as well.


I noticed that one of above comments has the same build as my second one:

------- Additional comments from androbi Wed Jan 7 13:18:16 +0000 2009 -------

Same Problem in OOo 3.0.0 (OOO300m9, Build:9358) on WIN XP!!!

I'm not sure if it is because of different language version, but mine acts just 
fine.

Thank you.
Comment 14 mreiter 2010-02-26 23:19:20 UTC
In 3.2.0 (German) on Win XP+SP3 and Win7 everything works fine even with more
than 20 extensions installed. 
Comment 15 vvzh 2010-07-08 19:09:21 UTC
I can still reproduce it with OOo 3.2.1 (OOO320M18 Build 9502) on Windows XP SP2
with Writer2xhtml extension and hyphenation/dictionaries installed as extensions.
Comment 16 oooforum (fr) 2019-10-12 13:10:02 UTC
Windows XP or Vista is outdated now