Issue 88623 - New Document from Template Closes when opening second document
Summary: New Document from Template Closes when opening second document
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 2.4.0
Hardware: PC Windows, all
: P3 Normal (vote)
Target Milestone: 4.1.0
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-23 05:40 UTC by corigo
Modified: 2017-05-20 10:35 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description corigo 2008-04-23 05:40:01 UTC
1. Double click on an ott file and a New Document opens with the template 
content.
2. Double click on an odt file
3. ODT file is open, but my new document from the OTT is gone, closed, 
disappeared. Where did it go?

What I am trying to do:
I have created templates for contracts, invoices, etc. I open the new document 
from my ott then I open an ODT so I can cut and paste the address and customer 
information into my new document. Unfortunately as soon as I open the ODT my 
New Document into which I wish to paste... is gone.
Comment 1 jolatt 2008-04-23 07:45:46 UTC
Confirming. But perhaps this is wanted.

If you enter something in the New Document before opening the ODT its o.k.

Open the ODT file first!


Comment 2 corigo 2008-04-23 09:54:32 UTC
RE: Your comments...

My template is complete. The only thing I need to do is paste in my client's 
information. 

Opening the ODT is not a logical progression. My goal is to create a new 
invoice. After I open the new document ... then I realize I need the address... 

It is not a major issue, obviously, and yes I have already figured out the work 
arounds, but it is certainly anomolous behaviour when compared to other 
document editors.
Comment 3 michael.ruess 2008-04-28 09:30:51 UTC
Framework issue.
Comment 4 mux2005 2009-11-26 14:01:14 UTC
I see this under Linux, too. OS should be "All".
Comment 5 Rainer Bielefeld 2013-11-17 07:26:51 UTC
Reproducible with "Ooo 2.0.3 [680m5 (Build 9011)]" German WIN7 Home Premium  (64bit):

1. In OOo Start Center File Dialog 'Open - sometextdocument.ott'
   (I used a document with lots of contents)
   > "Untitled 1.odt" will be shown with lots of contents
2. From new document's File Dialog 'Open - sometextdocument.odt' in the
   same folder
   As expected "sometextdocument.odt" will be opened
   Bug: "Untitled 1.odt" has disappeared

Additional Info:
----------------
(a) it does not matter whether I use OS File Dialog or OOo File Dialog.
(b) no longer reproducible with "Ooo 3.1.1 German WIN7  Home Premium  (64bit) 
    DE [OOO310m19 (Build 9420)]"!
(c) Has been fixed for AOO 3.1.1 (or more early),
   but because of crippled Target Milestone selector contents 
   (Bug 123063) I only can select TM = 4.1.0, no correct
   information can be contributed.
Comment 6 oooforum (fr) 2014-07-09 09:58:34 UTC
It looks like that [Fixed] status is set prematurely. 
Always reproductible with AOO 4.1.0

Thanks to reopen