Issue 88648 - PXL import filter seems to be broken
Summary: PXL import filter seems to be broken
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOo 2.4.0
Hardware: HP (PA-RISC) Windows XP
: P2 Trivial with 8 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2008-04-23 14:54 UTC by oalexmay
Modified: 2013-01-29 21:45 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

This is a file saved with oo. Can't open it with oo though. (11.15 KB, application/
2008-04-23 14:55 UTC, oalexmay
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description oalexmay 2008-04-23 14:54:13 UTC
I can save a pocket excel file from oo but having saved it I can't open it.
If I try, first I get asked which application to use and then oo tries to open 
it as a text file.
If I try to open it from oo and give it the file type, I get a blank sheet.
Comment 1 oalexmay 2008-04-23 14:55:41 UTC
Created attachment 53140 [details]
This is a file saved with oo. Can't open it with oo though.
Comment 2 oalexmay 2008-04-23 14:56:54 UTC
Should have said that pocket excel can open the file, just not oo.
Comment 3 redflagzhulihua 2008-06-18 09:35:59 UTC
I can confirm this issue in OOo2.4.0

1. Creat a clac document and save it as PXL format 
2. Open this PXL file with clac.  //OOo requires a character set
3. After a choice, the document is opened with writer.
4. Choose PXL in the filter and open the PXL file.
5. An empty calc document appears
Comment 4 dcoshea 2009-02-08 09:03:43 UTC
I have a PC running Fedora 7 with the Sun JRE installed plus OpenOffice 2.3.0
installed using the Fedora-supplied RPMs:

$ rpm -qa | grep openoffice

Using this installation of OpenOffice, I was able to open the attached file
(attachment #53140 [details]) when I manually selected the correct file type in the file
open dialog.  All the text just appears as squares (that must be a separate
issue) but I can see plenty of numbers; there is content up to row 23 and column
F.  I started OpenOffice from the command line by running 'ooffice' and can
confirm that no errors appear in the console.

I installed OpenOffice 2.3.0 and 2.4.2 using RPMs generated (as far as I can
tell) by - not Fedora.  I installed the RPMs using a separate RPM
databases under /opt so that they could all co-exist.  When I tried to use
either of these versions to open the attached .pxl file, a .pxl file I generated
myself using Pocket Excel on Pocket PC 2002, or a .psw file I generated myself
using Pocket Word on Pocket PC 2002, I always got a blank spreadsheet/document.
 In all cases, the following error message appeared on the console:

Exception in OfficeDocument.write() No
appropriate API (JAXP/Xerces) to serialize XML document:

I have another PC running Fedora 10 without the Sun JRE installed.  It has
OpenOffice 3.0.0 installed using the Fedora RPMs:

$ rpm -qa | grep openoffice

I get the same behaviour as above (blank spreadsheet/document and the same error
message on the console) when I try to open the .pxl/.psw files using this
version of OpenOffice in this environment.

As above, I installed the RPMs for a number of versions
of OpenOffice (2.3.0, 2.4.2 and 3.0.1) on this Fedora 10 PC and saw the same
behaviour with all of them.

It seems most interesting that OpenOffice 2.3.0 behaves differently on the same
PC depending on whether it is distributed by or Fedora.  I note
that Fedora seem to use quite a few patches to the distribution.  This is a stab
in the dark, but I note that

%configure --with-build-version=%{name}-%{version}-%{release}
--with-unix-wrapper=%{name} --disable-ldap --disable-crashdump --disable-epm
--disable-qadevooo --disable-fontooo --disable-mathmldtd --disable-pasf
--disable-Xaw --with-ant-home=/usr/share/ant %{jdkflags} --enable-gstreamer
--enable-symbols --enable-lockdown --enable-evolution2 --enable-cairo
--enable-vba --enable-dbus --with-system-libs --with-system-vigra
--with-system-hunspell --with-system-python --with-system-mozilla=firefox
--with-system-boost --with-system-libwpd --with-system-icu
--with-system-odbc-headers --with-system-sane-header
--with-system-xrender-headers --with-system-libxslt  --with-system-hsqldb
--with-system-beanshell --with-system-db --with-system-xml-apis
--with-system-xerces --with-system-xalan --without-system-mspack
--without-system-xt --without-system-neon --without-fonts --without-nas
--without-gpc --without-agg --without-ppds --without-afms %{stlflags}
--with-lang="%{langpack_langs}" --with-poor-help-localizations="$POORHELPS"

Since the error message references
"" I wonder if the use of
--with-system-xerces causes the Fedora-packaged OpenOffice 2.3.0 to use a
different class.  The Fedora-packaged OpenOffice 3.0.0 doesn't seem to include
this flag (I may not have checked properly).  I see at
(which seems to be the source file generating the error message) that if the
class in use were "org.apache.xerces.dom.DocumentImpl" it looks like there would
be no error, and perhaps that is the class that is used if --with-system-xerces
is in use?  I have not investigated that far yet.
Comment 5 dcoshea 2009-10-04 05:25:24 UTC
On my same PC running Fedora 10 without the Sun JRE installed, I now have newer
Fedora-supplied OpenOffice RPMs:

$ rpm -qa | grep openoffice

When I try to open the same .pxl/.psw files using this version of OpenOffice in
this environment, they seem to be opened with at least some of the data there;
in the case of the .psw file, there was at least one sentence missing from the
end of the document; I haven't done a more detailed comparison of either document.

I got this error message on the console when opening the first file (the .pxl file):

[Java framework] could not load Java runtime library: 

I have not investigated that error message further; since the files are loaded,
I assume it doesn't matter.
Comment 6 lilianfrank44 2011-04-26 12:14:11 UTC
 My name is Lilian i saw your proffle here and admire it i think we can make it together, therefore i would like you to contact me back throug my email address thus:  i will tell you more about myself and i will also send you my photo as soon as you contact me back. Hopping to hear from you soonest, UNDERSTAND THAT LOVE IS ONE, Lilian WITH LOVE AND TRUST Love & Kiss.