Issue 88959 - OOo hangs when File > Save is selected with new document on Windows Vista
Summary: OOo hangs when File > Save is selected with new document on Windows Vista
Status: CLOSED DUPLICATE of issue 87244
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: BEA300m2
Hardware: PC Windows Vista
: P3 Trivial (vote)
Target Milestone: ---
Assignee: thorsten.martens
QA Contact: issues@framework
Depends on:
Reported: 2008-05-02 18:57 UTC by
Modified: 2008-05-09 03:27 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description 2008-05-02 18:57:17 UTC
On Windows Vista, OO.o hangs when File > Save is selected from main menu. I have
been noticed this behavior from DEV300_m10 to BEA300_m2.

Steps to reproduce (On Windows Vista),

1. Open OOo-dev Writer.
2. Type some text.
3. Select File > Save from main menu.
4. Confirm that OOo hangs.
5. Repeat from 1 to 4 with Calc, Impress, Draw.
Comment 1 2008-05-02 19:01:57 UTC
I forgot to mention that this issue does not happen on Windows XP. :-)
Comment 2 2008-05-02 19:15:09 UTC
I just found that this only happens with *new* document. When I ran 'File >
Save' or 'File > Save As' after editing existing document, it worked as expected.

FYI, 'File > Save' with new document is supposed to pop up 'Save As' dialog
which I guess this issue related to. 
Comment 3 teffetalor 2008-05-03 06:32:39 UTC
I can confirm and reproduce this problem, I am running Vista Home Premium 32bit.
As a note save to PDF works fine. Using the shortcut Ctrl - S also causes a
hang, and the hang affects all open windows of the program for me.
Comment 4 khirano 2008-05-07 23:35:21 UTC
Hi Jeongkyu,

Your DEV300_m10's Writer hanged, didn't it?

Does your BEA300_m2's Writer hang?
Comment 5 2008-05-08 04:42:23 UTC
@khirano: Yes, it happens with BEA300_m2 on Windows Vista.
Comment 6 khirano 2008-05-08 04:52:52 UTC
I am using OOo_3.0.0beta_20080429_Win32Intel_install_wJRE_ja.exe
It doesn't hang.
Which build are you using, Jeongkyu?
Comment 7 2008-05-08 05:07:49 UTC
@khirano: What kind of dialog did you set to use in The dialog does not cause this issue, but Windows dialog does.

By the way, I could reproduce this issue with
OOo-Dev_BEA300_m2_Win32Intel_install_en-US.exe &
Comment 8 khirano 2008-05-08 05:29:51 UTC
Jeongkyu, you are right.

I rebooted Windows Vista and opened 3.0 Beta Writer, then typed some text, and
tried to save the document.  Writer didn't respond.
Comment 9 2008-05-08 05:43:31 UTC
@khirano: Thanks for your test. Considering that saving a new document is very
basic task, this seems to be very critical issue for Windows Vitsa users.
Comment 10 khirano 2008-05-09 02:00:03 UTC
Hi Jeongkyu,

I think this issue is a duplicate of i87224.

If you think it is, please verify and close this issue.


*** This issue has been marked as a duplicate of 87224 ***
Comment 11 khirano 2008-05-09 02:06:40 UTC
*** This issue has been marked as a duplicate of 87224 ***
This is wrong.
Comment 12 khirano 2008-05-09 02:07:51 UTC
duplicate of 87244

*** This issue has been marked as a duplicate of 87244 ***
Comment 13 2008-05-09 03:27:53 UTC
@khirano: Thanks for finding the dupe! Closing...