Issue 89000 - Loop when opening document containing frames/tables anchored in header/footer
Summary: Loop when opening document containing frames/tables anchored in header/footer
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: viewing (show other issues)
Version: OOo 2.4.0
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: regression
Depends on:
Blocks: 88258
  Show dependency tree
 
Reported: 2008-05-04 14:49 UTC by potowotoumi
Modified: 2013-08-07 14:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
attaching linked document for posterity (41.68 KB, application/vnd.oasis.opendocument.text)
2008-05-05 20:04 UTC, aziem
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description potowotoumi 2008-05-04 14:49:08 UTC
Hello,

I just noticed that I have several odt and doc files that i cannot open with
OpenOffice 2.4. The program freezes on windows, ubuntu and mac.

It worked without any problems in version 2.0 and 2.3. Even when I open the
doc-file and save it with OO 2.0 it's imposible to open it with OpenOffice 2.4
or later.

To rebuild this error you can download example files:

http://www.ausgleichende-gerechtigkeit.de/test.odt
http://www.ausgleichende-gerechtigkeit.de/test.doc

It worked with:
OpenOffice (Win XP) 2.0 
OpenOffice (Win XP/Portable) 2.3
 
It crashed on:
OpenOffice 2.4 (Win XP/Portable)
OpenOffice 2.4 (Ubuntu 8.04)
OpenOffice 3 Dev-Snapshot (Mac OS X 10.5.2)
Comment 1 michael.ruess 2008-05-05 09:07:16 UTC
MRU->FME: mentioned document will cause a loop in Writer right after the import
/ opening process since OO 2.4. Could you please have a look if this is an
"unexpected" victim of the "loopcontrol"?
In the document there are many tables inside frame which are anchored inside the
header and footer.
Comment 2 frank.meies 2008-05-05 11:45:40 UTC
fme->od: As discussed, there's an infinite loop in SwHeadFootFrm::FormatSize()
which has been 'activated' by fixing an other issue.
Comment 3 Oliver-Rainer Wittmann 2008-05-05 14:56:15 UTC
defect cause found:
inconsistent calculation of height of the last line of paragraph
Comment 4 stefan.baltzer 2008-05-05 15:31:33 UTC
SBA: Set keyword "regression".
Comment 5 aziem 2008-05-05 20:04:48 UTC
Created attachment 53395 [details]
attaching linked document for posterity
Comment 6 Oliver-Rainer Wittmann 2008-05-06 08:37:29 UTC
fixed in cws sw241bf03 - changed file:
/sw/source/core/text/txtfrm.cxx, 1.102.110.1
Comment 7 Oliver-Rainer Wittmann 2008-05-06 09:49:34 UTC
OD->MRU: Checked in internal installation set of cws sw241bf03 - please verify.
Comment 8 michael.ruess 2008-05-07 13:24:32 UTC
Verified fix in CWS sw241bf03.
Comment 9 michael.ruess 2008-05-07 14:19:26 UTC
Reopened to correctly set to "verified."
Comment 10 michael.ruess 2008-05-07 14:20:01 UTC
.
Comment 11 michael.ruess 2008-05-07 14:20:24 UTC
.
Comment 12 Mechtilde 2008-05-26 15:05:05 UTC
I delete the URL because there is no more the document

It works under Debian, verified in OOH_m16 -> closed