Issue 89080 - gtk file picker: preview/link persistence broken
Summary: gtk file picker: preview/link persistence broken
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: current
Hardware: All All
: P3 Trivial (vote)
Target Milestone: 3.4.0
Assignee: marc.neumann
QA Contact: issues@framework
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2008-05-06 20:34 UTC by thb
Modified: 2017-05-20 10:30 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description thb 2008-05-06 20:34:39 UTC
With the fix for issue 77905, the gtk filepicker no longer remembers the state
of the link and preview checkbox (e.g. when inserting a graphic in Impress). The
changes to sfx2/source/dialog/filedlghelper.cxx (loadConfig: only load 'Link'
and 'Preview' states from configuration if not overwritten by another instance)
seems a bit coincidental to me - at least the api ref doesn't state that
getValue() should return a NIL any, if no value has been set previously. At any
rate, the gtk file picker implementation does not exhibit this behaviour,
therefore loadConfig() does not apply the settings.
Comment 1 thb 2008-05-06 20:38:26 UTC
was working in 2.3
Comment 2 Frank Schönheit 2008-05-06 21:52:15 UTC
What about fixing the API ref and the GTK file picker? :) Well, admittedly the
NULL Any thingie might be strange ...

Okay, the alternative would probably be to introduce some kind of "respect the
following config settings" flags at the file picker. Ugly, but the whole story
of how configuration in the file picker is handled is ugly, it can hardly become
worse.

Given that you're one of the most experienced developers in the OOo code base, I
am sure you can come up with a patch for this?
Comment 3 Frank Schönheit 2011-03-14 21:56:08 UTC
targeting to 3.x since its a regression
Comment 4 Frank Schönheit 2011-03-16 13:20:11 UTC
fixed in CWS fs34b
Comment 5 Frank Schönheit 2011-03-29 08:36:00 UTC
fs->msc: please verify in CWS fs34b
Comment 6 marc.neumann 2011-03-31 13:35:03 UTC
verified in cws fs34b