Issue 89211 - Retain currently installed language tools when installing new version
Summary: Retain currently installed language tools when installing new version
Status: CLOSED DUPLICATE of issue 72559
Alias: None
Product: General
Classification: Code
Component: spell checking (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: Other Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: requirements
QA Contact: issues@lingucomponent
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-09 01:05 UTC by othr
Modified: 2013-02-24 20:43 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description othr 2008-05-09 01:05:04 UTC
Each time I install a new version of OOO, I have to manually reinstall the  
dictionary and thesaurus files for the various languages I use.

I would like the OOO installer to do this automatically. I would like the OOO 
installer to determine which language tools are installed for the current 
version, and keep them working for the upgraded version.
Comment 1 Olaf Felka 2008-05-09 08:49:09 UTC
reassigned
Comment 2 thomas.lange 2008-05-09 08:57:47 UTC
That is you downloaded some dictionaries manually and after upgrade they are
gone (or at least non-functional)?
In that case this will be a duplicate of issue 72559.

Please state if that was all what you were doing?
(If you know where to look you could even check if the actual dictionaries were
still there after the upgrade)
Comment 3 othr 2008-05-09 09:32:18 UTC
I can usually find the dictionaries somewhere - although from memory the file 
that lists the installed dictionaries gets overwritten, so I keep a backup copy.

I think this is probably a duplicate of 72559. The whole upgrade process with 
respect to dictionaries is unecessarily messy. I think a few lines of code 
would fix it:
1) "Find existing dictionary.lst file"
2) move/copy this file and all referenced files in the list to the directory of 
new installation
3) move/copy dictionary.lst file to the new location
4) register the above with the new version of the software (I suspect this step 
already happens automatically on boot up, but I can't remember for sure)
Comment 4 thomas.lange 2008-05-09 11:36:32 UTC
Yes that file with the list of dictionaries is the dictionary.lst which is th
cause for all the trouble when it simply gets overridden.
For OOo 3.0 we will get rid of that file an make use of extensions for
dictionaries as well.

Just for the interested ones:
http://wiki.services.openoffice.org/wiki/Extension_Dictionaries

Reading your comments I think it is safe to set this one as duplicate to issue
72559.

*** This issue has been marked as a duplicate of 72559 ***
Comment 5 Mechtilde 2008-11-05 21:22:06 UTC
close the duplicate