Issue 89262 - X11+cairo: CJK/Thai/Arabic text not visible in vertical mode or when zoomed in
Summary: X11+cairo: CJK/Thai/Arabic text not visible in vertical mode or when zoomed in
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 3.0 Beta
Hardware: PC Unix, all
: P2 Trivial with 4 votes (vote)
Target Milestone: OOo 3.0
Assignee: stefan.baltzer
QA Contact: issues@gsl
URL: http://blog.vee-u.com/2008/05/10/ooo-...
Keywords:
: 88973 90421 90804 90959 92270 92278 (view as issue list)
Depends on: 88973
Blocks: 89974 90287 88888 92671
  Show dependency tree
 
Reported: 2008-05-10 06:51 UTC by vsatayamas
Modified: 2009-07-20 15:56 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
An example document for reproducing the issue (8.56 KB, application/vnd.oasis.opendocument.text)
2008-05-10 06:52 UTC, vsatayamas
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description vsatayamas 2008-05-10 06:51:14 UTC
Writer does not display Thai text properly when it was zoomed in. In fact, Thai
text is disappeared when I zoom in but if i don't zoom or zoom out, it is okay.
Comment 1 vsatayamas 2008-05-10 06:52:54 UTC
Created attachment 53525 [details]
An example document for reproducing the issue
Comment 2 vsatayamas 2008-05-10 06:59:17 UTC
screencast: http://www.youtube.com/watch?v=zIy-1_DTNQU 
Comment 3 michael.ruess 2008-05-10 18:53:39 UTC
Reassigned to SBA.
Comment 4 tora3 2008-05-29 11:44:04 UTC
http://gsl.openoffice.org/servlets/ReadMsg?list=dev&msgNo=2171

=====
The phenomenon - glyphs disappear in certain conditions - has been also
reported in the Japanese community. It seems to application neutral.

Changing text direction from Left-to-right (horizontal) to Right-to-left
(vertical) also makes glyphs invisible.

The transparent glyphs seem to remain there. Action of moving cursor seems
to work fine. Exporting the document with invisible characters into PDF
format seems to work.

The phenomenon can be observed with recent DEV300 variants on Linux.

What type of information does help you look into it?
=====
Comment 5 caolanm 2008-05-29 17:54:10 UTC
Lets try and rule some things in or out

Does export SAL_DISABLE_CAIROTEXT=1 make a difference ?

I cannot see your video, so at what point size does text disappear ?
Comment 6 tora3 2008-05-29 18:53:54 UTC
With "export SAL_DISABLE_CAIROTEXT=1", the problematic phenomenon has gone. 

Without the environment variable, in horizontal writing, Japanese characters 
appear in equal or less than 14.6pt; they disappear in more than 14.6pt. 
In the case of vertical writing, Japanese characters appear in equal of less 
than 5.5pt; they disapper in more than 5.5pt.

Target: OOo_3.0.0beta_20080429_LinuxIntel_install_en-US.tar.gz (BEA300_m2)
OS: Fedora 8, SELinux: Permissive
Application: Writer
Magnification: 100%
Fontname: Sazanami Mincho 
LANG: both LANG= and LANG=ja_JP.UTF-8 bring the same results.

.openoffice.org3/user/psprint/pspfontcache:
FontCacheDirectory:1198918311:/usr/share/fonts/sazanami-fonts-mincho
File:sazanami-mincho.ttf
2;1
Sazanami Mincho;ã•ã–ãªã¿æ˜Žï¿½;Sazanami;ã•ã–ãªã¿æ˜Žï¿½;Sazanami M;ã•ã–ãªã¿æ˜Žï¿½;Sazanami
Min;ã•ã–ãªã¿æ˜Žï¿½;Sazanami Minch;ã•ã–ãªã¿æ˜Žæœ
-1;Sazanami-Mincho-Regular;0;6;

grep "Sazanami Mincho" pspfontcache | iconv -f UTF-8 -t UCS-2 | od -x
0000000 0053 0061 007a 0061 006e 0061 006d 0069
0000020 0020 004d 0069 006e 0063 0068 006f 003b
0000040 3055 3056 306a 307f 660e fffd 003b 0053
0000060 0061 007a 0061 006e 0061 006d 0069 003b
0000100 3055 3056 306a 307f 660e fffd 003b 0053
0000120 0061 007a 0061 006e 0061 006d 0069 0020
0000140 004d 003b 3055 3056 306a 307f 660e fffd
0000160 003b 0053 0061 007a 0061 006e 0061 006d
0000200 0069 0020 004d 0069 006e 003b 3055 3056
0000220 306a 307f 660e fffd 003b 0053 0061 007a
0000240 0061 006e 0061 006d 0069 0020 004d 0069
0000260 006e 0063 0068 003b 3055 3056 306a 307f
0000300 660e 671d 000a

ufffd REPLACEMENT CHARACTER is included. why?

xdpyinfo:
  resolution:    81x90 dots per inch
  depths (7):    24, 1, 4, 8, 15, 16, 32
  depth of root window:    24 planes
Comment 7 caolanm 2008-05-29 19:53:37 UTC
I can see this on one of my machines, but not the other two. Let me see if I can
debug it
Comment 8 caolanm 2008-05-30 10:43:57 UTC
The nGlyphFlags |= GF_UNHINTED in vcl/source/glyphs/gcach_ftyp.cxx for CJK text
causes this grief 

If the use fontconfig hints patch at
http://qa.openoffice.org/issues/show_bug.cgi?id=64508
is applied then this problem goes away

We could either apply that, or disable the cairo text stuff
Comment 9 hdu@apache.org 2008-05-30 12:15:57 UTC
@cmc: thanks for debugging into this regression introduced by issue 85470. I don't understand yet why 
cairo would make glyphs invisible when their hinting is different?
Comment 10 caolanm 2008-05-30 12:39:00 UTC
Yeah, I don't understand either.
Comment 11 hdu@apache.org 2008-06-02 10:19:22 UTC
*** Issue 88973 has been marked as a duplicate of this issue. ***
Comment 12 hdu@apache.org 2008-07-25 11:56:51 UTC
Aaargh... I overlooked the fact that the cairo-codepath ignores the "extended glyph flags", e.g. for glyphs 
in vertical layouts or when hints get disabled.

Will be fixed in CWS vcl30stop2.
Comment 13 philipp.lohmann 2008-07-25 12:22:45 UTC
block
Comment 14 hdu@apache.org 2008-07-25 14:21:22 UTC
Fixed in CWS vcl30stop2:
- the nohinting flag gets ignored now in the cairo codepath
- in vertical writing mode the non-cairo codepath is taken for now
Comment 15 hdu@apache.org 2008-07-25 14:28:29 UTC
Additional testing hints:
- load the bugdoc and zoom in (see the original bug description)
- enable Tools->Options->Languages->CJK
- select "right to left(vertical)" in Format->Page->Page->TextDirection
- add a mix of CJK+Latin+CTL characters
  -- for a font that natively supports vertical writing
  -- for a font that needs vertical writing support emulation

Comment 16 hdu@apache.org 2008-07-25 15:24:35 UTC
@sba: please verify on CWS vcl30stop2
Comment 17 hdu@apache.org 2008-07-31 08:40:06 UTC
*** Issue 92278 has been marked as a duplicate of this issue. ***
Comment 18 stefan.baltzer 2008-08-01 16:11:49 UTC
SBA: Verified in CWS vcl30stop2.
Comment 19 eric.savary 2008-08-21 15:31:55 UTC
*** Issue 90421 has been marked as a duplicate of this issue. ***
Comment 20 stefan.baltzer 2008-09-22 09:45:29 UTC
*** Issue 90959 has been marked as a duplicate of this issue. ***
Comment 21 hdu@apache.org 2009-02-02 08:43:15 UTC
*** Issue 90804 has been marked as a duplicate of this issue. ***
Comment 22 lohmaier 2009-04-24 08:46:17 UTC
*** Issue 92270 has been marked as a duplicate of this issue. ***
Comment 23 thorsten.ziehm 2009-07-20 15:56:48 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
http://download.openoffice.org/index.html
If you want to know more about the handling of fixed/verified issues =>
http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues