Issue 89448 - Original (picture) size broken
Summary: Original (picture) size broken
Status: CLOSED DUPLICATE of issue 49026
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 3.0 Beta
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-14 10:30 UTC by david
Modified: 2008-05-14 12:03 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Test image for the 'Original size' issue (481.13 KB, image/png)
2008-05-14 11:25 UTC, david
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description david 2008-05-14 10:30:36 UTC
1. Import a png using Insert/Picture/From file - for example picutre I attached 
to this issue.

2. notice how big the picture is - the user will assume this is the original 
size.

3. grab the lower right corner and pull left so that it gets tall and slim.

4. right-click and click Picture...

5. click Original size and click OK

6. notice that this new size is definitely NOT the size it originally had when 
importat.

7. notice that this new size is definitely NOT the right apect ratio.

8. think about how the user would reset the picture to the right aspect ratio 
and correct size... it's impossible - especially if the picture is only in the 
document and not on her harddisk anymore.

9. try keep aspect ratio - this doesn't help at all.. there's no way to 


I think original size is unpredictable for any user. I have no idea what will 
happen when I click it - other than never what I need or expect.

I think Original size should always return to the original aspect ratio - and 
any normal user will need an Original aspect button too. I think this should be 
very easy to reach - in the right click menu on a picture - and not hidden away 
in the picture details/settings.

Cheers
- David
Comment 1 david 2008-05-14 11:25:23 UTC
Created attachment 53617 [details]
Test image for the 'Original size' issue
Comment 2 michael.ruess 2008-05-14 12:02:32 UTC
Same root cause as issue 49026.

*** This issue has been marked as a duplicate of 49026 ***
Comment 3 michael.ruess 2008-05-14 12:03:19 UTC
Closing duplicate.