Issue 89453 - Print preview colors wrong - not WYSIWUG
Summary: Print preview colors wrong - not WYSIWUG
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Writer
Classification: Application
Component: viewing (show other issues)
Version: OOo 3.0 Beta
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
URL:
Keywords:
: 90044 (view as issue list)
Depends on:
Blocks:
 
Reported: 2008-05-14 11:29 UTC by david
Modified: 2008-05-30 11:23 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Test Windows Theme for Print preview color issue (1.51 KB, application/x-compressed)
2008-05-14 11:32 UTC, david
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description david 2008-05-14 11:29:52 UTC
If you use dark background color and/or non-standard text-color in your Windows 
theme OO3 shows print preview wrongly.

OO3 uses the operating system colors for the page and text instead of applying 
the actual printed document colors as you would expect from a print preview. 
Thereby print preview has no reliable WYSIWUG.

This behaviour would make the unsuspecting user think the color of the text is 
totally wrong. And could even be white on white or black on black.

I've attached a test theme for repro. Notice that the text color in normal mode 
is correct - it's the windows colors - but the print preview shows the text in 
white too - this is wrong.

Cheers
- David
Comment 1 david 2008-05-14 11:32:09 UTC
Created attachment 53618 [details]
Test Windows Theme for Print preview color issue
Comment 2 michael.ruess 2008-05-14 13:29:14 UTC
Reassigned to HI.
Comment 3 ace_dent 2008-05-28 08:52:17 UTC
*** Issue 90044 has been marked as a duplicate of this issue. ***
Comment 4 h.ilter 2008-05-30 11:04:22 UTC
HI->ES: Please take over for accessibility.
Comment 5 eric.savary 2008-05-30 11:17:13 UTC
"Tools - Options - OpenOffice.org - Accessibility: 
Use system colors for page previews [OFF]"
Comment 6 eric.savary 2008-05-30 11:17:32 UTC
Closed
Comment 7 david 2008-05-30 11:23:51 UTC
PERFECT ! thanks! :)