Issue 89486 - Font menus oversimplify set of available fonts, show wrong preview
Summary: Font menus oversimplify set of available fonts, show wrong preview
Status: CLOSED DUPLICATE of issue 29364
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 3.0 Beta
Hardware: Mac Mac OS X, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-14 23:15 UTC by etiffany
Modified: 2019-01-13 23:53 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description etiffany 2008-05-14 23:15:05 UTC
This issue applies across all OOo apps, wherever there is a font selection menu.

The Font menu in the Toolbar (and also in the context popup) oversimplifies the
list of available fonts, where a variety of typefaces exist.  Furthermore, the
font preview shown in the toolbar menu seems to be selected at random from the
available typefaces for that font, and does not match the typeface of the
characters inserted into the document.

For example, in Writer activate the Font toolbar and scroll down until you get
to "Helvetica Neue".  The example text is actually rendered in the font
"Helvetica Neue Light", but if you select the menu entry Helvetica Neue, and
type some text, it will appear in "normal" weight Helvetica Neue.

If you right-click on this text, and select "Character..." from the popup, and
then look at the Font tab, you will see there is one font Helvetica Neue and 13
different "typefaces" listed.  

If you select the text, and right click to get the context popup, the Style
submenu does not list Light as an option.

So there is no convenient way to type text in (e.g.) Helvetica Neue Light.  You
must type the text and then go through the Formatting window.

For comparison, Word 2008 lists Helvetica Neue and four other variations as
Fonts (Helvetica Neue Black Condensed, Helvetica Neue Bold Condensed, Helvetica
Neue Light, and Helvetica Neue UltraLight).  Each of these has four options for
"font style" of Regular, Italic, Bold, Bold Italic.

Not that Word should be the exemplar, but at least you can easily get what you
want pretty easily, and what you see is what you get.
Comment 1 michael.ruess 2008-05-15 08:47:55 UTC
Reassigned to ES.
Comment 2 discoleo 2008-05-16 20:03:17 UTC
1.) The Regular, Italic, Bold, and Bold Italic should be selected automatically
by the application without any user input. So, when a user selects *Bold* for
his text, and a true bold typeface does exist for that specific font, OOo shall
automatically use the *Bold* typeface.

2.) I do agree though that it might be useful sometimes to have all fonts
(including all typefaces) displayed. Unfortunately, users need most of the time
only a couple of fonts. In the current font list-box implementation, displaying
them all will be counterproductive.

There are a couple of possibilities to solve this issue:
2.a.) One is described in issue 15421:
      http://qa.openoffice.org/issues/show_bug.cgi?id=15421

   Display only some fonts (let user specify which ones).

 2.b.) Advanced Font Categories
   As previously mentioned, sometimes we might want to find the perfect font
   from the very big list of fonts. In this instance, the drop-down list is
   NOT very effective.

In order to provide the user with a better overview of the available fonts, I
started a brainstorming session how to sort fonts based on some tangible font
properties: like horizontal or vertical length of characters, weight of the
font, some parameters of compactness, and possible other characteristics, see:
http://wiki.services.openoffice.org/wiki/User_Experience/ToDo/Product/Font_Categories

Having such advanced sorting options will indeed permit displaying *ALL* font
typefaces, because every typeface will have at least a different 'weight' and
'compactness'.

I am open to other suggestions as well, and hope to be able to persuade the
developers to implement it.
Comment 3 eric.savary 2008-05-26 16:42:19 UTC
Reassigned to Requirements
Comment 4 etiffany 2008-05-28 01:43:55 UTC
Hmm, I sort of object to this being reclassified as an enhancement, because the
font selection worked much better in previous versions of OOo (2.4 and earlier)
on MacOS.  
Comment 5 Peter 2019-01-13 21:51:07 UTC
Imho this is an duplicate to the linked issue.

*** This issue has been marked as a duplicate of issue 29364 ***