Issue 89619 - Problems when adding "Recent Documents" or "load URL" icons to toolbar
Summary: Problems when adding "Recent Documents" or "load URL" icons to toolbar
Status: CONFIRMED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 2.4.0
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2008-05-18 23:22 UTC by pclough
Modified: 2013-01-29 21:47 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description pclough 2008-05-18 23:22:19 UTC
When customising a toolbar:

(1) when adding the "Recent Documents" icon, the icon appears on the toolbar as
it should but clicking on it yields no result, despite the fact that the submenu
"File/Recent Documents" contains 10 items.

(2) when adding the "Load URL" icon, an eddress var appears as it should; but
when opening its drop-down, it shows not only the URLs loaded previously but
also the list shown by "File/Recent Documents" together with other older disk
files which do not appear in this menu.  This happens whether or not the "Recent
Documents" icon has been added to the toolbar. Maybe this is by design, but it
is confusing and clutters the screen.

(3) assume following scenario:
    - load any text document in print layout
    - create a new toolbar using standard toolbar as a model, adding the "Load
URL" icon and save it as standard-user
    - select standard-user instead of standard via the "View/Toolbar" menu
    - type http://mydomain.org/file.html in the address bar - the URL is loaded
as it should in a new document in web layout - however there is no longer any
address bar and the "standard-user" toolbar is not selectable from this layout
via the View/toolbar menu (I think I understand why - I should have created a
similar "standard-user" toolbar in web layout first, but it seems to be a
complicated way of doing things and would be worth simplifying). In addition
when switching back to the text document in print layout, its address bar shows
the URL loaded in the other window, which must be wrong
    - finally close the html document; then instead of the address bar of the
text document containing the path of its file, or being blank (if it is
dedicated to true URLs) what appears there is the URL of the document I just
closed, which must be wrong too.

I hope this is of some use!
Comment 1 michael.ruess 2008-05-19 12:09:46 UTC
Framework issue.
Comment 2 Regina Henschel 2008-08-28 23:00:22 UTC
Problems with Recent Documents" are already tracked in issue 49785 and issue
69168. So this issue should be only about the "load URL" field.

The "load URL" field might not work as you aspect, but it has no error. Changing
the behavior would be an enhancement.