Issue 89930 - OpenOffice.org 3 Windows 98/ME support
Summary: OpenOffice.org 3 Windows 98/ME support
Status: CLOSED OBSOLETE
Alias: None
Product: porting
Classification: Code
Component: code (show other issues)
Version: OOo 3.0 Beta
Hardware: Unknown Windows 98
: P3 Trivial with 36 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-25 17:45 UTC by forsoft
Modified: 2017-10-18 17:59 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description forsoft 2008-05-25 17:45:41 UTC
The beta version of the OpenOffice 3.0 does not work with Windows 98/ME.

The Windows 9x systems are still supported by the MSFN community. The KernelEx 
project added some level of Windows 2000/XP application support on Windows 98. 
The ability to run OpenOffice 3 in Windows 98 systems is an important matter 
for users of older Microsoft systems.

So, we are asking to keep the support for the Windows 98. The KernelEx makes it 
compatible with Windows 2000/XP to some level. But, it will be very difficult 
to istall it without some sort of support to our cause in the OpenOffice 
installer.
Comment 1 fredledingue 2008-05-25 22:55:35 UTC
*** Issue 89930 has been confirmed by votes. ***
Comment 2 forsoft 2008-06-11 10:28:07 UTC
It's quite possible the OpenOffice 3 will be able to work in Windows 98 as is, 
without additional changes. Still, I'm unable to test it, as the setup 
procedure reports a proper version of Microsoft Installer missing.

I know no way of tricking the Microsoft Installer 3 based setup procedure to 
work on Windows 98. A change in the setup system can give the ability to setup 
and test the compatibility of KernelEx and OpenOffice 3.

Is there a way to use a different setup procedure in the OpenOffice 3 series? 
If not, it will be necesary to build own Windows 98 installation compatible 
release, probably. 
Comment 3 reklamy 2008-06-11 19:49:58 UTC
Why OpenOffice 3.0 does not work with Windows 98/ME?
Comment 4 forsoft 2008-06-11 20:52:46 UTC
The support for Windows 98 and ME was withdrawed intentionaly, as far as I know.

The developers decided the amount of Windows 98 and ME users is too small for 
the amount of work necesary to keep the compatibility with these systems.

------------------

According to the setup.ini file from the OpenOffice 3 beta setup package, it 
requires just the Microsoft Installer 2. But, I'm receiving the message there 
are no proper installer service available.
Comment 5 nospam4obr 2008-06-12 06:24:49 UTC
What happens if you double-click the openofficeorg30.msi file ?
Comment 6 forsoft 2008-06-12 06:33:21 UTC
Double clicking on the openofficeorg30.msi file makes setup to do some work. 
But, at the end, it looks like almost all .EXE files are missing. Apparently, 
the openofficeorg30.msi does not contain all the necesary files.
Comment 7 nospam4obr 2008-06-12 06:49:38 UTC
There are two 'program' directories nowadays - did you check both ?
Comment 8 forsoft 2008-06-12 07:35:12 UTC
Indeed, I've foung the .EXE files.

Sadly, I'm unable to launch any of them, as an "Incorrect Parameter" 
(translated from Polish language) error message is displayed. I do not know if 
the message is comming from the OS or the OpenOffice application. Does the beta 
support other than English language error messages?
Comment 9 Stephan Bergmann 2008-06-12 08:57:54 UTC
At least some (but strategically important) code now uses the Unicode (...W)
versions of Windows functions, which, AFAIK, are not available on Windows 98/ME,
and the emulation code we used before has either been removed or is no longer
reachable (due to the distribution of code to three layers).  It is IMO a
fruitless (and even counterproductive) effort to try and get OOo running on
Windows 98/ME, after it has been decided to drop support for that platform, and
developers started to take advantage of that in their code
additions/modifications (read: simplifications).
Comment 10 Martin Hollmichel 2008-06-13 09:13:59 UTC
mark issue as unassigned, since I will not work on that issue.

If there are people volunteering for this effort, I recommend to create an
childworkspace (cws) for these efforts to collect necessary changes for keep
this run on Win98 and to have the impossibly to keep those efforts in sync with
latest OOo relaseses. 

@sb,hro: I recommend not to "simplify" the code not to fast, to raise not too
high hurdles for people who want to volunteer for this effort.

@forsoft: Simplifying code is quite important for maintainability and code
quality, so I think we have to find volunteers for this effort quite fast
otherwise we need to continue "simplification".
Comment 11 forsoft 2008-06-15 12:45:23 UTC
I'm not a KernelEx expert, but it does provide some Unicode translation 
functionality to the Windows 98 OS.

The latest changes in the KernelEx extension made running Firefox 3 possible in 
the Windows 98.

If it will be possible to force OpenOffice 3 applications to run in Windows 98, 
it will be possible to tell what other functions needed for the OpenOffice 3 
are missing in the KernelEx extension. What I'm counting on is the Windows 
standard error messages telling what library fuctions are still missing.

Getting the information about the missing Win32 API functions support is the 
key to the ability to run the OpenOffice 3 as it is now. With the knowledge of 
what functions are missing, it will be possible to tell, if it will be easier 
to implement them in KernelEx or to remove them for OpenOffice 3.
Comment 12 kwibus_ 2008-06-15 13:58:22 UTC
I 'd love to help with porting Open office to win 98
I have very little knowlege about programming though just a little basic and IDL
Which programming languages do you use?

I had problems installing first as well.
I used kernelex 0.3.4 
When i tried to reinstal Microsoft installer it said it was already installed.
after removing MSIexec.exe it did reinstall and the installer worked normally 
afterwords. The MSI version in use now is 2.0.2600.2 
Comment 13 forsoft 2008-06-15 16:22:11 UTC
To persuade the OpenOffice 3 beta to run on a Windows 98 I do have to know what 
is done on every start of every OpenOffice application. I do believe it checks 
some enviroment variables, or something like that. Since there are no certain 
variables in Windows 98, the application refuses to start. I just do not know 
what particular variables I need to create.

The problem can be related to some certain registry keys missing, as well.
Comment 14 rainyd 2008-06-15 18:25:30 UTC
Because I really like OpenOfiice I'd love to see a possibility to run the
upcoming version 3.0 on Win98/ME, but we need at least a minimum support from
the developers.
Comment 15 forsoft 2008-10-23 11:57:42 UTC
I've just tested the OO 3 with the just released KernelEx 0.3.6. And, it works.

So, if there will be no new Win NT only functions introduced, the OO 3 will 
continue to run on the Window 98/ME operating systems.
Comment 16 gs_comput 2008-10-24 12:15:03 UTC
OOo 3.0 for win98
Comment 17 martg 2008-11-16 18:10:21 UTC
The KernelEx page for OOo 3.0 reports that 0.3.6 seems to cooperate with OOo
3.0, but with some reservations -- http://x86.neostrada.pl/KernelEx

OOo 3.0 for Windows 9x is important, as it's the only free software office
package I know that would allow reading MSO2007 files.

Advanced users may convert to or create a dual-boot environment with a
lightweight Linux or BSD system, but this would be a stretch for everyone else.
Note that many computers that are well able to run Windows XP were sold with
Windows 98 or Me preinstalled.

I wonder how Mac people with older and capable hardware that's forced to be with
older OS X's feel like...
Comment 18 martg 2009-07-21 23:58:02 UTC
Update:
I've noticed that Go-Oo 2.4.x offers Office Open XML import (
http://en.wikipedia.org/wiki/Go-oo#Filetype_support ) out of the box, but has
some other disadvantages.

I have not tried OOo 3.0.x out with KernelEx, although the most desirable new
functionality in 3.0 is the new Notes implementation.
Comment 19 oooforum (fr) 2017-10-18 14:31:49 UTC
These versions are obsoletes