Issue 89933 - Documents open read-only
Summary: Documents open read-only
Status: CLOSED OBSOLETE
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOo 3.0 Beta
Hardware: Mac Mac OS X, all
: P3 Trivial with 6 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-25 19:56 UTC by dirkma
Modified: 2019-11-16 23:18 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description dirkma 2008-05-25 19:56:56 UTC
If I open a ods file from a network share (Samba Server 3.0.28a) it opens in
read only mode only.

In other programs like NeoOffice I can work on this document directly from
network. If the same file is copied locally before open it is working too.

A Writer file (odt) on the same share doesn't show this failure, so it seems to
be on Calc only.
Comment 1 clytie 2008-06-27 14:58:31 UTC
DEV300_m21 Intel Leopard: I have this problem in this build, and I have had it in previous builds, not 
from network docs, but from docs from my own user directory on my own hard drive!

I return to spreadsheets I've been editing over previous days (for example, I keep one open for tax 
info, and one to keep track of the translators in our project), and when I try to edit it, OpenOffice.org 
says it's read-only. It wasn't last time I edited it in that same session.

The most recent occurrence was today, when after one of OpenOffice.org Aqua's intermittent silent 
crashes, I reopened those two spreadsheet docs. From the moment of opening, they were read-only. I 
have no idea why. They weren't in the previous OpenOffice.org session. But this is definitely a 
problem. :(

I've renamed the issue to "Documents open read-only", since it isn't only happening with network 
shares.
Comment 2 oc 2008-06-27 15:10:00 UTC
This could be because of the filelocking feature recently introduced in the
OOo3.0 codeline. Please check if there is no file named .~lock.filename.ods#
If such a file (in the same directory as the original) exists and the document
is not opened by OOo anymore this lockfile should be deleted and this issue closed
Comment 3 dirkma 2008-06-27 19:01:33 UTC
I tried to confirm this issue again and now it worked as expected. No read-only
from samba share and local filesystem.

Seems that Leopard 10.5.3 changed something in this area.
 
Comment 4 exexcel 2008-11-08 18:43:09 UTC
I have the same problem with ooo 3.0.0 on ubuntu 8.10 with ods-files on a
samba-server (NAS box, don't know samba-version, mounted as cifs).

Opening a file is always in read-only-mode, even if no ~lock-file exists. A
~lock-file is then created. The ~lock doesn't get deleted after closing the file
(probaly that's skipped because of the read-only-mode which normaly would make ok).
Comment 5 creativecom 2009-08-13 16:55:31 UTC
I have the same issue using 3.01 and 3.1 with files on a Network share (Mac OS X
10.5.7. When trying to open files (text documents) from the server if I did not
copy or create the file it will be read only. Example, there is a file on my
server that I did not create, when I open it, it is read-only. If copy the file
to my desktop and then copy and replace the file on the server, I can now open
it without the Ready-Only happening. But that file cannot be opened by someone
else without the Read-Only happening. This does not happen with any other
program, Word, Adobe products, etc, and files on our server, only Openoffice. I
can even take the same file that opens as read-only in OpenOffice and open it in
Word or TextEdit and it is fine.

The issue seems to be that Openoffice is only reading the individual permissions
on the files and not the group permissions on the server. This basically makes
OpenOffice useless in a business environment.
Comment 6 fe1 2009-10-20 14:43:26 UTC
Using calc 3.1.1 (OOO310m19) I have this issue also. My files, however, are
local. I'm in the owner's group and have rw permission. The owner can open them rw.

Clicking the "Edit file" shortcut informs me that "This document cannot be
edited, possibly due to missing access rights" etc. Other files in the same
directory can be edited as expected. No locking file is present.
Comment 7 fe1 2009-10-20 14:46:06 UTC
Excuse the double post. Thought it may be relavant I'm not on Mac; I'm running
debian.
Comment 8 oooforum (fr) 2019-11-15 15:05:55 UTC
.