Issue 9068 - Table does not display entire contents (or indication of extra)
Summary: Table does not display entire contents (or indication of extra)
Status: CLOSED DUPLICATE of issue 2623
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.0.0
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-11-08 07:01 UTC by Unknown
Modified: 2003-09-08 16:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
File showing problem, see cell "Upper Hall..." (24.04 KB, application/octet-stream)
2002-11-08 07:03 UTC, Unknown
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2002-11-08 07:01:14 UTC
This bug was noticed in both Windows 2000 and Windows 98 using the 1.0.0
release, basically, there's a user interface issues wherein a table cell which
has (apparently) an attribute for fixed-height has more text than can be
displayed within the cell.  

The cell gives no indication that there is extra text, and does not scroll to
display the cursor if the user moves into extra text.  As a result the user
becomes confused (there is no visible cursor).  Telling the cells to use
"optimal" spacing displays the text, and makes further changes properly update
the display.

This was brought to my attention when a user attempted to save a file with the
described structure as a Word document and reimport into the application.  The
result was that a different part of the text was displayed within the cell (so,
to the user, it appeared that the application had scrambled together multiple
documents (the extended contents in the cells are just pieces left over from
multiple edits of the document)).

I would suggest offering a graphic clue that there is extra text in the cell
(for instance an arrow pointing down when the user's cursor is in the cell), and
would strongly suggest that moving down while within the cell to areas of text
not currently displayed should scroll the cell's contents to display the hidden
text.

As a side note, the Word filter probably should be looked at to see if changing
the displayed sub-section is supposed to occur on a round-trip.

As a note, this file was originally created on an old version of Microsoft Word
running on a Macintosh, and was imported by open office running on a PC.
Comment 1 Unknown 2002-11-08 07:03:35 UTC
Created attachment 3520 [details]
File showing problem, see cell "Upper Hall..."
Comment 2 frank.meies 2002-11-08 07:26:53 UTC
FME: See #i2623#

*** This issue has been marked as a duplicate of 2623 ***
Comment 3 michael.bemmer 2003-03-11 17:22:02 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details. First step in IssueZilla is
unfortunately to set them to verified.
Comment 4 michael.bemmer 2003-03-11 17:26:28 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details. First step in IssueZilla is
unfortunately to set them to verified.
Comment 5 michael.bemmer 2003-03-11 17:27:48 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details. First step in IssueZilla is
unfortunately to set them to verified.
Comment 6 michael.bemmer 2003-03-11 17:38:07 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details.