Issue 91025 - Can't build connectivity/source/drivers/evoab2/NStatement.cxx
Summary: Can't build connectivity/source/drivers/evoab2/NStatement.cxx
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: DEV300m20
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: kurt.zenker
QA Contact: issues@dba
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-24 19:47 UTC by pmladek
Modified: 2017-05-20 10:27 UTC (History)
2 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Proposed fix. (700 bytes, patch)
2008-06-24 19:48 UTC, pmladek
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description pmladek 2008-06-24 19:47:43 UTC
I get the following build error with dev300-m21:

--- cut ---
In file included from
/usr/src/packages/BUILD/ooo-build-2.99.4m/build/dev300-m21/connectivity/source/drivers/evoab2/NStatement.hxx:58,
                 from
/usr/src/packages/BUILD/ooo-build-2.99.4m/build/dev300-m21/connectivity/source/drivers/evoab2/NStatement.cxx:43:
/usr/src/packages/BUILD/ooo-build-2.99.4m/build/dev300-m21/connectivity/source/drivers/evoab2/EApi.h:63:
warning: type qualifiers ignored on function return type
/usr/src/packages/BUILD/ooo-build-2.99.4m/build/dev300-m21/connectivity/source/drivers/evoab2/NStatement.cxx:
In member function 'rtl::OUString
connectivity::evoab::OStatement_Base::getTableName()':
/usr/src/packages/BUILD/ooo-build-2.99.4m/build/dev300-m21/connectivity/source/drivers/evoab2/NStatement.cxx:406:
error: 'getTableRange' was not declared in this scope
dmake:  Error code 1, while making '../../../unxlngx6.pro/slo/NStatement.obj'
--- cut ---

The problem was caused by the changes for the issue #84290.

The fix is easy. I'll attach a patch for this.
Comment 1 pmladek 2008-06-24 19:48:36 UTC
Created attachment 54716 [details]
Proposed fix.
Comment 2 ocke.janssen 2008-06-25 06:38:48 UTC
Could you please integrate this patch as well. Thanks.
Comment 3 kurt.zenker 2008-07-29 16:06:57 UTC
fixes as masterfix in ooo300 m1 and dev300 m29