Issue 91071 - Better Polish AutoCorrect File
Summary: Better Polish AutoCorrect File
Alias: None
Product: Internationalization
Classification: Code
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P2 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@l10n
Depends on:
Blocks: 109046
  Show dependency tree
Reported: 2008-06-25 18:20 UTC by milek_pl
Modified: 2013-08-07 15:02 UTC (History)
8 users (show)

See Also:
Latest Confirmation in: ---
Developer Difficulty: ---

New autocorrect file (7.66 KB, application/x-compressed)
2008-06-25 18:20 UTC, milek_pl
no flags Details
Corrected autocorrect file (7.64 KB, application/x-compressed)
2008-11-12 16:26 UTC, milek_pl
no flags Details
Corrected autocorrect file (2nd ver) (7.70 KB, application/x-compressed)
2008-11-27 16:12 UTC, milek_pl
no flags Details
Corrected autocorrect file (META-INF bug) (7.73 KB, application/x-compressed)
2010-03-23 17:13 UTC, milek_pl
no flags Details
af-ZA (5.12 KB, application/x-compressed)
2010-05-18 16:29 UTC, weko
no flags Details
da-DK (7.29 KB, application/x-compressed)
2010-05-18 16:30 UTC, weko
no flags Details
en-ZA (8.05 KB, text/plain)
2010-05-18 16:30 UTC, weko
no flags Details
mn-MN (4.15 KB, application/x-compressed)
2010-05-18 16:31 UTC, weko
no flags Details
en-ZA (now with correct MIME type) (8.05 KB, application/x-compressed)
2010-05-18 16:32 UTC, weko
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description milek_pl 2008-06-25 18:20:02 UTC
I attach a new version that corrects some problems with the current autocorrect
file (there were some duplicates & one entry was a false alarm). I file it as
enhancement but because there is a little error in the previous autocorrect, it
also fixes a defect, that's why I'd like to ask to integrate it into 3.0.

Comment 1 milek_pl 2008-06-25 18:20:53 UTC
Created attachment 54741 [details]
New autocorrect file
Comment 2 milek_pl 2008-06-25 18:22:45 UTC
assigning to va
Comment 3 weko 2008-07-18 12:30:21 UTC
VA: New autocorrection file will be integrated in OOo 3.0.1.
Comment 4 weko 2008-09-22 15:06:42 UTC
Set target to OOo 3.1.
Comment 5 weko 2008-11-12 15:54:00 UTC
@milek: Could you please provide me 2 or 
3 example entries, which you modified, so we can verify the fix/enhancement. 
Thanks in advance.
Comment 6 milek_pl 2008-11-12 16:25:44 UTC
@vl: good that you asked, I've seen another mistake there ("za granicą" should
not be changed). Attaching a new version.

Test it on "maja" (deleted, was changed to "mają" before), "aż nad to" -> "aż
nadto" (added), "chba" -> "chyba" (added).

Comment 7 milek_pl 2008-11-12 16:26:42 UTC
Created attachment 57944 [details]
Corrected autocorrect file
Comment 8 weko 2008-11-27 14:55:25 UTC
@milek: Could you please recheck your updated AutoCorrection-List? I get only 7 
entries: --, -->, ->, ..., (c), (r) and (tm). But the file size seems to be okay: 7,63 KB 
(new), 7,64 KB (old).
Comment 9 milek_pl 2008-11-27 16:10:16 UTC
va: you're right, I didn't notice I needed entities conversion. This time I
checked it twice, attaching a still newer version...
Comment 10 milek_pl 2008-11-27 16:12:07 UTC
Created attachment 58347 [details]
Corrected autocorrect file (2nd ver)
Comment 11 weko 2008-11-27 16:21:58 UTC
AutoCorrection List looks good now.

Checked in. - Thanks, Milek.
Comment 12 weko 2008-12-19 16:45:36 UTC
@sba: Please verify.
Comment 13 stefan.baltzer 2009-01-20 11:06:46 UTC
Verified in CWS extras310.
Comment 14 milek_pl 2010-01-07 19:16:09 UTC
It seems that in 3.2 RC1 it got replaced by some ancient and useless version of
the file. Could you please check what happened?
Comment 15 stefan.baltzer 2010-01-15 16:46:31 UTC
SBA->OS: In the Tools - AutoCorrect Options dialog, the Polish AutoCorrect
Replacement list is empty in OOO320_m9.

- The file I can find in /share/autocorr/ has a size of 8 kB and after
un-zipping it, it shows a lot of entries and looks good at first glance.
So the file is in the installation.
- When I changed something (add or remove an entry), this file should be copied
to /user/autocorr/ and get modified accordingly. This does not take place.  
- Manually copying the file to /user/autocorr/ still shows an empty list.
- Created a new replacement pair for Polish, closed and reopened the dialog and
the list is empty again.

I tried other languages, too. As far as I can see, only PL is affected. This can
not be a general encoding problem because Russian and Farsi lists work well.
Comment 16 milek_pl 2010-03-23 17:12:20 UTC
@sba, va:

I found the reason. The internal directory "META-INF" was "Meta-inf" in the
Polish file. While it worked in the past, starting from 3.2, only META-INF
works. I changed this and voila, everything works fine. The attached version is
the correct file.

As this is a trivial change of a directory name and the issue is annoying, I
would ask to accept this change for 3.2.1 (I already adjusted the summary).

Comment 17 milek_pl 2010-03-23 17:13:51 UTC
Created attachment 68503 [details]
Corrected autocorrect file (META-INF bug)
Comment 18 Oliver Specht 2010-05-18 08:32:06 UTC
reassigned to va
Comment 19 Oliver Specht 2010-05-18 08:32:20 UTC
Comment 20 weko 2010-05-18 13:45:46 UTC
Comment 21 weko 2010-05-18 14:11:00 UTC
Fixed in CWS SDK321.

@sba to verify this patch just unzip the AutoCorr file located here: InstallationPath/.../Basis/share/
autocorr/acor_pl-PL.dat - There must be a directory called "META-INF" instead of "Meta-inf".
Comment 22 weko 2010-05-18 14:22:06 UTC
@sba: Please verify when CWS is ready for QA.
Comment 23 gibi 2010-05-18 14:36:38 UTC
I've just checked all acor*.dat in OOO320m17 (3.2.1rc1) Linux X64 en-US:

1) some of them have both META-INF/manifest.xml and Meta-inf/manifest.xml
with redundant informations.

For example in acor_da-DK:
in META-INF/manifest.xml:
 <manifest:file-entry manifest:media-type=""
and furthermore:
 <manifest:file-entry manifest:media-type="" manifest:full-path="Meta-inf/"/>
 <manifest:file-entry manifest:media-type="" manifest:full-path="META-INF/"/>

L10n affected:
 - af-ZA
 - da-DK
 - en-ZA
 - af-ZA

2) Another language is broken in 3.2 like PL: mn-MN (mongolian)

Should it be submitted as new issues?
Comment 24 stefan.baltzer 2010-05-18 15:16:13 UTC
Issue reopened.
Comment 25 stefan.baltzer 2010-05-18 15:18:15 UTC
Adding some CCs.
SBA->VA: Please proceed.
Reassigned to VA.
Comment 26 weko 2010-05-18 16:17:22 UTC
Okay, these files will be fixed, too:

- af-ZA
- da-DK
- en-ZA
- mn-MN
Comment 27 weko 2010-05-18 16:27:38 UTC
Comment 28 weko 2010-05-18 16:29:46 UTC
Created attachment 69514 [details]
Comment 29 weko 2010-05-18 16:30:25 UTC
Created attachment 69515 [details]
Comment 30 weko 2010-05-18 16:30:55 UTC
Created attachment 69516 [details]
Comment 31 weko 2010-05-18 16:31:17 UTC
Created attachment 69517 [details]
Comment 32 weko 2010-05-18 16:32:30 UTC
Created attachment 69518 [details]
en-ZA (now with correct MIME type)
Comment 33 weko 2010-05-18 16:34:42 UTC
@sba: [Again ;-)] Please verify. AutoCorr files are attached.
Comment 34 stefan.baltzer 2010-05-19 14:53:29 UTC
Note: With the wrong MIME stuff cases, newly enterd AutoCorr entries for the
respective languages (i.e. replace aa with aaa) vansihed after the dialog was
closed and reopened.
Now pl-PL, af-ZA, da-DK, en-ZA and mn-MN work well.
Verified in CWS sdk321.
Comment 35 stefan.baltzer 2010-05-26 08:21:18 UTC
OK in OOO320_m18. Closed.