Issue 91101 - Open the attached document (.doc ) causes OOo to crash
Summary: Open the attached document (.doc ) causes OOo to crash
Status: CLOSED DUPLICATE of issue 89480
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: DEV300m20
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: openoffice
QA Contact: issues@sw
URL:
Keywords: oooqa, regression
Depends on:
Blocks:
 
Reported: 2008-06-26 15:19 UTC by eric.bachard
Modified: 2013-08-07 14:43 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
.doc causing instant crash with Aqua version (144.50 KB, application/msword)
2008-06-26 15:20 UTC, eric.bachard
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description eric.bachard 2008-06-26 15:19:25 UTC
The attached document cannot be open -> Aqua version does crash every time.

Tested with m21 + aquavcl08 on Tiger Intel.
Comment 1 eric.bachard 2008-06-26 15:20:48 UTC
Created attachment 54762 [details]
.doc causing instant crash with Aqua version
Comment 2 philipp.lohmann 2008-07-01 14:41:25 UTC
Not mac specific, works the same e.g. on Linux. Crash as follows:

#0  0xafc9908a in vtable for SvxTextForwarder ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/program/libsvxli.so
#1  0xaf598da0 in OutlinerParaObject::SetVertical ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/program/libsvxli.so
#2  0xaf2346c0 in SdrObjCustomShape::SetVerticalWriting ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/program/libsvxli.so
#3  0xafa458c3 in SvxMSDffManager::ImportShape ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/program/libsvxli.so
#4  0xafa43fab in SvxMSDffManager::ImportObj ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/program/libsvxli.so
#5  0xafa4eca9 in SvxMSDffManager::GetShape ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/program/libsvxli.so
#6  0xadcd6ed2 in ?? ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/program/libswli.so
#7  0xadcea5cd in ?? ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/progr---Type
<return> to continue, or q <return> to quit---
am/libswli.so
#8  0xadce9fb8 in ?? ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/program/libswli.so
#9  0xadceb2ea in ?? ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/program/libswli.so
#10 0xadcf0553 in ?? ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/program/libswli.so
#11 0xadcf2352 in ?? ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/program/libswli.so
#12 0xadcf35e9 in ?? ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/program/libswli.so
#13 0xadcf383a in ?? ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/program/libswli.so
#14 0xadb79aa8 in ?? ()
   from
/export/home/pl/vcl91/office/opt/staroffice9/program/../basis-link/program/libswli.so
Comment 3 Mechtilde 2008-07-05 08:55:00 UTC
under Linux it is a regression.

It works with 2.4.1

I set to P2 because of the crash
Comment 4 openoffice 2008-07-07 12:16:14 UTC
Changed target.
Comment 5 sven.jacobi 2008-07-07 13:05:40 UTC
sj: This bug is double to issue 49480 which is fixed in Dev300 m23.

*** This issue has been marked as a duplicate of 89480 ***
Comment 6 caolanm 2008-07-07 13:42:33 UTC
close as dup