Issue 91133 - problems with demoted lists - incorrect tab handling in lists from OOo 2.x documents
Summary: problems with demoted lists - incorrect tab handling in lists from OOo 2.x do...
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: DEV300m20
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2008-06-27 13:15 UTC by avagula
Modified: 2013-08-07 14:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description avagula 2008-06-27 13:15:50 UTC
I created example file with dev_m20:
http://ftp.linux.ee/pub/openoffice/contrib/images/test30.odt
It looks like this in dev_m20:
http://ftp.linux.ee/pub/openoffice/contrib/images/test1.png (tabs are offset by
demoting space, so when I want to align numbers in column, it is not possible)
Opened the same file in 2.4 (looks like I dont have 2.4.1 installed) - file
looks like this: http://ftp.linux.ee/pub/openoffice/contrib/images/test2.png
(demoting is gone at all).
Created new example file with 2.4:
http://ftp.linux.ee/pub/openoffice/contrib/images/test24.odt
Looks like this, all pretty:
http://ftp.linux.ee/pub/openoffice/contrib/images/test3.png
Opened same file with m20:
http://ftp.linux.ee/pub/openoffice/contrib/images/test4.png (demoting exact like
in first picture, not possible to arrange numbers)
Made additional move: saved test24 file with m20 and opened with 2.4, at least
demoting itself is preserved, ie looks exact like test3.png not like test2.png.
All files are saved in ODF 1.1 format.
Resume1: created with 3.0 demoted list is not correctly saved for 2.4
Resume2: when demoted lines have tabs inside, then principe of tabs placement is
different in 2.4 and 3.0 and I dont find it good
Comment 1 Oliver-Rainer Wittmann 2008-06-27 14:33:04 UTC
First described problem regarding lists - create a text document in DEV300m20 or
OOo 3.0 Beta and open it in OOo 2.x - is already covered by issue 89178.

The second described problem regarding tab handling in lists - create a text
document in OOo 2.x and open it in DEV300m20 or OOo 3.0 Beta - is a serious
defect. It is a regression. Has to be fixed in OOo 3.0.

Thus, the tab handling in lists, which use the former list level attributes,
have to be corrected.

Additional note:
The positions of the tab stops are depending on the left margin of the paragraph
- the positions are relative to the left margin. In lists using the new list
level attributes - see specification " New position and space attributes for
list levels of a list style" found at
http://specs.openoffice.org/writer/numbering/NewListLevelAttrs.odt - the left
margin of the paragraph is also given by the list level attributes. Thus, the
tab stop position can differ between paragraph on different list levels.
Comment 2 Oliver-Rainer Wittmann 2008-07-01 10:48:53 UTC
fixed in cws sw30bf08 - changed files:
/sw/source/core/text/txttab.cxx, 1.31.120.1
/sw/source/core/text/itrtxt.hxx, 1.20.130.1
/sw/source/core/text/itrcrsr.cxx, 1.80.28.1
/sw/inc/ndtxt.hxx, 1.58.32.1
/sw/source/core/txtnode/ndtxt.cxx, 1.83.30.1
Comment 3 Oliver-Rainer Wittmann 2008-07-10 09:05:44 UTC
OD->MRU: Checked in internal installation set of cws sw30bf08 - please verify.
Comment 4 michael.ruess 2008-07-10 13:51:31 UTC
Verified in CWS sw30bf08.
Comment 5 michael.ruess 2008-08-15 09:14:56 UTC
Checked in build OOO300m2.