Issue 91140 - Moving of grouped connectors causes wrong path
Summary: Moving of grouped connectors causes wrong path
Status: CLOSED DUPLICATE of issue 29210
Alias: None
Product: Draw
Classification: Application
Component: ui (show other issues)
Version: OOo 2.4.0
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: Armin Le Grand
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-27 14:53 UTC by skudpond
Modified: 2013-08-07 15:40 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
bugdoc (7.68 KB, application/vnd.oasis.opendocument.graphics)
2008-06-30 12:23 UTC, wolframgarten
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description skudpond 2008-06-27 14:53:41 UTC
I'm experiencing what I consider a little odd behavior related to grouping
connectors in Open Office draw. The version I found it in is 2.4 running on
vista however it is reproducible in 2.2 running on my Mac as well. It may
actually be expected behavior but it really screws up my connectors.

Basically when I group two connectors and then double click on that connector
group it seems to put that group in a different state, perhaps a group edit
mode??? It seems to work reasonably well with rectangles and circles in a group
but when I use connectors they screw up. If you need more information please
feel free to contact me and I can make a video capture of my screen or something.

Please follow these steps exactly:

1) Draw "Rectangle A"
2) Draw "Rectangle B"
3) Draw "Line Connector C" connecting from "Rectangle A" to unconnected location
in middle of page
4) Draw "Line Connector D" connecting from "Rectangle B" to unconnected end of
"Line Connector C". Make sure the two ends of the connectors join with one another
5) Hold down <Shift>, select C and D and then right click mouse button and
select "Group" from the popup context menu. This will group the two connectors.
6) Double click on the new grouped connectors.
7) "Rectangle A" and "Rectangle B" change to a light color and are now locked
for some reason, even though they weren't part of the group. This can be
resolved by double clicking in an empty spot in the drawing (BUT DON'T DO THAT YET)
8) Create "Rectangle E" and "Rectangle F".
9) Group just the two new rectangles (make sure you don't double click anywhere
in order to keep A and B still showing in lighter color, i.e. still locked)
10) Without double clicking, move the new group (E and F) around. They look fine
and are independent of the first group of connectors.
11) Double click in a blank space in the drawing. This should bring "A" and "B"
back to normal color.
12) Move the grouped "Rectangle E and F". When you do they now also move the two
line connectors that were part of another group. Moving the grouped "E and F"
around a bit royally screws up the position of the line connectors that should
have been in the separate group created in step 5.
Comment 1 wolframgarten 2008-06-30 11:46:37 UTC
This works, in most parts, as designed. In step 6 you enter the group of the two
connectors. Now you are in the group, thats why rectangle A and B get the light
color: they are not in the group and cannot be edited as long as you are in the
group.
When in step 8 and 9 you group rectangle E and F you are creating a new group
within the first group. You did not leave the first group so everything you do
happens in this group.
step 11 leaves the first group (connectors).
With step 12 you move the first group and the second group contained in it.
Comment 2 wolframgarten 2008-06-30 12:22:13 UTC
The only thing that really is a problem is the behaviour of the grouped
connectors. Changing summary for that and attaching bugdoc.
Comment 3 wolframgarten 2008-06-30 12:23:36 UTC
Created attachment 54837 [details]
bugdoc
Comment 4 wolframgarten 2008-06-30 12:24:20 UTC
Reassigned.
Comment 5 Armin Le Grand 2008-07-02 15:39:23 UTC
Added note
Comment 6 Armin Le Grand 2008-07-02 15:44:00 UTC
AW: Double to #i29210#

*** This issue has been marked as a duplicate of 29210 ***
Comment 7 Armin Le Grand 2008-07-02 15:45:00 UTC
Closing due to duplicate