Issue 91368 - Deleting Column/Row changes font to default
Summary: Deleting Column/Row changes font to default
Status: CLOSED DUPLICATE of issue 8461
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOo 2.4.0
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-04 06:34 UTC by White Phoenix
Modified: 2008-08-22 00:04 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description White Phoenix 2008-07-04 06:34:57 UTC
I am using XP Home Edition SP2

When a column or row is deleted it should not affect the font formatting
anywhere or the size of the row(s)/column(s).

Regards,
White Phoenix
Comment 1 amy2008 2008-08-12 08:19:26 UTC
Can't reproduce it in DEV300_m28 on WinXP.
Comment 2 amy2008 2008-08-12 08:21:17 UTC
whitephoenix,
Please confirm it in the latest build asap.
Comment 3 White Phoenix 2008-08-16 12:11:57 UTC
Sorry, my ISP had problems sending mail over the last few days. (They sent me an
email on this.) I am just now catching up and will check again and report back
this afternoon at the latest.
Comment 4 White Phoenix 2008-08-16 19:13:16 UTC
I am using 2.4.1 now. The font type doesn’t seem to be affected, but the font
size is. If the row or column is moved or deleted it happens. When a column is
moved or deleted all the rows change. When a row is moved or deleted only the
cells in that row change. When they are moved the cells in the new location
retain the proper font size.

If a cell or group of cells are moved or cut this happens in the cells that are
emptied, but not if they are deleted using the delete key.

Along with the change in font size, the text alignment is also changed to the
default. If the contents of a left-aligned cell are moved to another cell, the
original cell reverts to default.
Comment 5 redflagzhulihua 2008-08-20 09:10:21 UTC
Hi whitephoenix,

Do you mean character format are set to default if some formated cells are 
moved to another places?
If so, I can get the same result you have.
I'm not sure if this is a bug. Because, by now, I don't know how the 
specification defined the empty cells left.
But I tested this with Excel: Move a row, the format don't change. but if you 
move a collumn, something intersting will happen: sometimes cells are set to 
default and sometimes remain the original format.
Comment 6 frank 2008-08-20 09:34:46 UTC
Hi,

it seems to me that this is a double to Issue 75935 and therefore to Issue 8461.

To make a decisiion if it's so, please describe step by step how to reproduce
the problem you've encountered.

Frank
Comment 7 White Phoenix 2008-08-21 03:30:23 UTC
I prefer all of my files to use Verdana 8 as default. I have set OpenOffice so
that Verdana instead of Arial is the default font, but I have to Select All and
then change the font size for my ODx files, or use a template.

Select a group of cells or just one cell. Move it or cut it. The row(s) will
adjust to the difference in font size. When you move the cursor to the vacated
cell(s) you will notice that the font size has changed. You will only notice
this if you use something other than the default size (10). Move a column or
row, or several, the row(s) will all adjust to the different font size. The font
size will show up in these cells as the default. It is related, perhaps, but the
original complaint was ALL formating was affected. Now it seems to be limited to
the font size. So you are getting closer to fixing the problem.
Comment 8 redflagzhulihua 2008-08-21 03:41:28 UTC
Sound same as the issues Frank mentioned.
If not, could you attach a sample document, and provide a step by step 
instruction based on that document, so that we can repeat your operation 
correctly?
Thank you.
Comment 9 frank 2008-08-21 09:02:25 UTC
Hi,

it's the same as Issue 75935 and Issue 8461 .

By selecting all cells and hard formatting the font and fontsize you did not
change the default settings. To make it easier for you and to avoid this row
height switching you may change the default cellstyle itself. This has numerous
advantages over your method including the no longer shown row height change and
maybe a decreasing file size. Not to mention the far easier changing of other
other cell attributes for all cells formatted using this style.

How to do ?
- Press F11 to open the Stylist (aka Styles and Formatting) 
- Select the default cell style
- Context menu on the Style and choose Modify
- Font tab page and change Font and Font size
- Click on Ok Button
as you can see the default font and size have been changed to your settings.

If you do this on a blank document and save it with File-Templates-Save and
afterwards use File-Templates-Organize-Commands-Set default template

you have to do this just once.

Frank

*** This issue has been marked as a duplicate of 8461 ***
Comment 10 frank 2008-08-21 09:03:00 UTC
closed double
Comment 11 White Phoenix 2008-08-22 00:04:54 UTC
    By selecting all cells and hard formatting the font and fontsize you did not
    change the default settings.

I never wrote that I did. I did not change the defaults. I wrote that when
cutting or moving the cells the fontsize reverted to the default in the cells
that were emptied.

    To make it easier for you and to avoid this row height switching you may 
    change the default cellstyle itself. . . .

Thanks, Frank. I am glad you understood what was happening. I have used Works
exclusively for years. Simple and basic so all you did was change the default
font and size in the program settings. The formatting that is in OpenOffice is a
little more complex, but I can see where it gives you more control and
flexibility. I just wasn’t use to this. 8-)

Yes, this is what I was looking for, but everyone else seemed to be hung up on
what I couldn’t do instead of what I could do to achieve the results that I wanted.

Thanks again.