Issue 91689 - The Windows installer is 'messy'
Summary: The Windows installer is 'messy'
Status: CLOSED DUPLICATE of issue 49861
Alias: None
Product: Installation
Classification: Application
Component: ui (show other issues)
Version: OOo 2.4.1
Hardware: Unknown Windows, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: Olaf Felka
QA Contact: issues@installation
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-16 03:03 UTC by zcat
Modified: 2008-07-16 07:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description zcat 2008-07-16 03:03:31 UTC
The Windows installer exe unpacks temporary files (setup.exe, cab files, etc) to
the user's desktop. They should probably be extracted to a /temp/ folder
somewhere. Also the installer doesn't clean up these temporary files when it's
finished. This would not be such a problem, except that the temporary folder it
doesn't clean up is on the user's Desktop. Non-technical users are often unsure
if it's safe to remove this folder, or if removing it will cause OpenOffice to
break.

I would like to the see the download installer use a proper temporary folder and
erase itself afterwards. 

I think it would also be a good idea for the OpenOffice CD image to simply
contain the whole uncompressed directory. The file size difference is minimal
and unpacking the 'real' installer from the 'single file' installer adds a long
and confusing delay to the CD install process.
Comment 1 Olaf Felka 2008-07-16 07:19:16 UTC
duplicate

*** This issue has been marked as a duplicate of 49861 ***
Comment 2 Olaf Felka 2008-07-16 07:19:49 UTC
closed
Comment 3 Olaf Felka 2008-07-16 07:20:18 UTC
..